关于安装多版本jdk,打开eclipse时,提示could not find java se runtime environment的解决banf

需要安装多版本jdk时,更改了java_home的配置后,在cmd中使用java -version 命令时,查看已经是最新版本,但是打开eclipse时,仍然提示could not find java se runtime environment。

原因:在安装JDK1.8之后,会自动将java.exe、javaw.exe、javaws.exe三个可执行文件复制到C:\Windows\System32目录。由于这个目录在WINDOWS环境变量中的优先级高于path设置的环境变量优先级。

解决方案:
    将C:\Windows\System32目录下的三个可执行文件删除。
    注意:当你按照上述操作之后,可能会意外的发现,然并卵。不要着急,首先先把dos窗口关闭,然后将环境path中的%JAVA_HOME%\bin;%JAVA_HOME%\jre\bin;放到最前面。最后重新打开dos窗口,输入java -version就会看到JDK1.7的相关信息啦。(此时JDK1.8环境中还没有配置) 

展开阅读全文

没有更多推荐了,返回首页