SDAU课程练习 2 1003

Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.<br><br>My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. <br><br>What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.<br>
 

Input
One line with a positive integer: the number of test cases. Then for each test case:<br>---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.<br>---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.<br>
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
  
3<br>3 3<br>4 3 3<br>1 24<br>5<br>10 5<br>1 4 2 3 4 5 6 5 4 2<br>
 

Sample Output
  
  
25.1327<br>3.1416<br>50.2655<br>
 

Source
NWERC2006


题目大意:

老师上课讲过的题目,分蛋糕,每人一块,尽可能使得分得的蛋糕最大,一个要求,每人分到的蛋糕必须是一整块,也就是,不可以两小块凑在一起。求出最大值。

思路:

蛋糕总量和人数成正比,满足单调关系,可以二分求最大值。区间为  0  -   sum / f    或者  max  /f  - sum/f   都可以,影响的是程序执行时间,不过都不会超时。

感想:

只是题目比较难懂一些,其他的还好啦。

AC代码:

#include<stdio.h>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
double pi=acos(-1.0);
double pie[10010];
double sum,maxn;
int main()
{
    int i,n,f,t,radio,num;
    double l,r,mid;
    scanf("%d",&t);
    while(t--)
    {
      scanf("%d%d",&n,&f);
      f++;
      maxn=sum=0;
      for(i=0;i<n;i++)
      {
         scanf("%d",&radio);
         pie[i]=pi*radio*radio;
         maxn=max(pie[i],maxn);
         sum+=pie[i];
      }
      l=maxn/f;
      r=sum/f;
      while(l+0.00001<r)
      {
        mid=(l+r)/2;
        num=0;
        for(i=0;i<n;i++)
          num+=(int)(pie[i]/mid);
        if(num<f) r=mid;
        else l=mid;
      }
      printf("%.4lf\n",l);
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值