SDAU课程练习2 1023

Another Eight Puzzle

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 3
Problem Description
Fill the following 8 circles with digits 1~8,with each number exactly once . Conntcted circles cannot be filled with two consecutive numbers.<br>There are 17 pairs of connected cicles:<br>A-B , A-C, A-D<br>B-C, B-E, B-F<br>C-D, C-E, C-F, C-G<br>D-F, D-G<br>E-F, E-H<br>F-G, F-H<br>G-H<br><center><img src=../../../data/images/C150-1010-1.jpg></center><br>Filling G with 1 and D with 2 (or G with 2 and D with 1) is illegal since G and D are connected and 1 and 2 are consecutive .However ,filling A with 8 and B with 1 is legal since 8 and 1 are not consecutive .<br><br>In this problems,some circles are already filled,your tast is to fill the remaining circles to obtain a solution (if possivle).<br>
 

Input
The first line contains a single integer T(1≤T≤10),the number of test cases. Each test case is a single line containing 8 integers 0~8,the numbers in circle A~H.0 indicates an empty circle.<br><br>
 

Output
For each test case ,print the case number and the solution in the same format as the input . if there is no solution ,print “No answer”.If there more than one solution,print “Not unique”.<br>
 

Sample Input
  
  
3<br>7 3 1 4 5 8 0 0<br>7 0 0 0 0 0 0 0<br>1 0 0 0 0 0 0 0<br>
 

Sample Output
  
  
Case 1: 7 3 1 4 5 8 6 2<br>Case 2: Not unique<br>Case 3: No answer<br>
 

Source
ECJTU 2008 Autumn Contest

题目大意:

         A

B       C      D
      
E       F       G

          H      

上面说的很清楚了,, A-B , A-C, A-D<br>B-C, B-E, B-F<br>C-D, C-E, C-F, C-G<br>D-F, D-G<br>E-F, E-H<br>F-G, F-H G-H
意思就是相邻位置上的数字不能相邻    嗯。再详细点就是看样例    1    。
        7 

3       1      4

5       8      6

         2
 嗯,就是这个意思。

思路:

和数独差不多,一个一个往里面填就行了,满足条件就输出,否则就回溯。另外就是输入的时候有空格,需要注意。

感想:

我是先写的数独,感觉数独解决之后,这几个还是挺顺利的。

AC代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<iostream>
#include<cstdio>
using namespace std;
int a[10],vis[10],temp[10],cou;
int isok()
{
	if(fabs(a[2]-a[1])!=1&&
		fabs(a[3]-a[1])!=1&&
		fabs(a[4]-a[1])!=1&&

		fabs(a[2]-a[3])!=1&&
		fabs(a[2]-a[5])!=1&&
		fabs(a[2]-a[6])!=1&&

		fabs(a[3]-a[4])!=1&&
		fabs(a[3]-a[5])!=1&&
		fabs(a[3]-a[6])!=1&&
		fabs(a[3]-a[7])!=1&&

		fabs(a[4]-a[6])!=1&&
		fabs(a[4]-a[7])!=1&&

		fabs(a[5]-a[6])!=1&&
		fabs(a[5]-a[8])!=1&&

		fabs(a[6]-a[7])!=1&&
		fabs(a[6]-a[8])!=1&&

		fabs(a[7]-a[8])!=1
		)
		return 1;
	else return 0;
}
void dfs(int num)
{
    int i;
	if(num==9)
		{
			if(isok())
			{
				cou++;
				if(cou==1)
				{
					for(i=1;i<=8;i++)
						temp[i]=a[i];
				}
			}
			return;
		}
    if(cou>=2) return;
    if(a[num]==0)
        for(i=1;i<=8;i++)
        {
            if(!vis[i])
            {
                a[num]=i;
                vis[i]=1;
                dfs(num+1);
                a[num]=0;
                vis[i]=0;
            }
        }
    else dfs(num+1);
}

int main()
{
    //freopen("r.txt","r",stdin);
	int t,casee=0;
	scanf("%d",&t);
	while(t--)
	{
	    casee++;
		cou=0;
		int i;
		memset(vis,0,sizeof(vis));
		memset(temp,0,sizeof(temp));
		for(i=1;i<=8;i++)
        {
            scanf("%d",&a[i]);//注意这里有个空格哦!
            vis[a[i]]=1;
        }
        for(i=1;i<=8;i++)
            if(a[i]==0)
                break;
        dfs(i);
        cout<<"Case "<<casee<<": ";
        if(cou==1)
        {
            cout<<temp[1];
			for(i=2;i<=8;i++)
                cout<<" "<<temp[i];
            cout<<endl;
        }
        else if(cou==2)
                cout<<"Not unique"<<endl;
        else
            cout<<"No answer"<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值