SDAU课程练习2 1025

Sequence two

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Problem Description
Search is important in the acm algorithm. When you want to solve a problem by using the search method, try to cut is very important.<br>Now give you a number sequence, include n (&lt;=100) integers, each integer not bigger than 2^31, you want to find the first P subsequences that is not decrease (if total subsequence W is smaller than P, than just give the first W subsequences). The order of subsequences is that: first order the length of the subsequence. Second order the subsequence by lexicographical. For example initial sequence 1 3 2 the total legal subsequences is 5. According to order is {1}; {2}; {3}; {1,2}; {1,3}. If you also can not understand , please see the sample carefully. <br>
 

Input
The input contains multiple test cases.<br>Each test case include, first two integers n, P. (1<n<=100, 1<p<=100000). <br>
 

Output
For each test case output the sequences according to the problem description. And at the end of each case follow a empty line.
 

Sample Input
  
  
3 5<br>1 3 2<br>3 6<br>1 3 2<br>4 100<br>1 2 3 2<br>
 

Sample Output
  
  
1<br>2<br>3<br>1 2<br>1 3<br><br>1<br>2<br>3<br>1 2<br>1 3<br><br>1<br>2<br>3<br>1 2<br>1 3<br>2 2<br>2 3<br>1 2 2<br>1 2 3
 

Author
yifenfei
 

Source
奋斗的年代

题目大意:

和上个题有什么不同的地方吗?
就是同一层的串在输出的时候要按照从小到大的顺序进行输出。
那么我们就想想啊,怎么样对上一份代码进行修改那?
额外的建立一个数组将每层数据保存吗?然后在输出的时候再排序?这样的话会超出内存吗?
如果检索到最后一层的话,需要多大内存?而且排序的时候费时那??显然是不现实的。
那么不如在输入数据之后就进行排序吧,这样做行得通么??
我们来看样例    3 5  1  3  2  和   3   6  1  3  2  
正常   做法        1     3     2
                    3        2          
                      
前五个    1                3                2                  1 3             1  2              

如果排序后再这样做     1    2     3
                                    2   3    3         
                                   3


样例他们输出都是一样的。可是如果排序的话  会出现     1   2   3                   2    3   这两个序列的啊 对不对?所以这种想法是不对的~

那么排序的时候就需要注意下标,先排数字再排下标。

好了,思路和感想都不写了

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct numberr
{
    int number;
    int postion;
};
bool cmp(const numberr &a,const numberr &b)
{
    if(a.number!=b.number)
        return a.number<b.number;
    return a.postion<b.postion;
}
numberr b[1005];
int a[1005];
int n,p,cou,dep;
int c[1005];
int dfs(int nowdep,int pos,int rr)
{
    if(nowdep==dep)
    {
        cou++;
        for(int i=0;i<nowdep-1;i++)
        {
            cout<<c[i]<<" ";
        }
        cout<<c[nowdep-1]<<endl;
        if(cou==p) return 1;
        return 0;
    }
    int pre,flag=0;
    for(int i=pos;i<=n;i++)
    {
        if(b[i].postion>rr)
        {
            if(!flag)
            {
                flag=1;
                pre=b[i].number;
            }
            else if(pre==b[i].number) continue;

        pre=b[i].number;
        c[nowdep]=b[i].number;
        if(dfs(nowdep+1,i+1,b[i].postion))
                return 1;
        }
    }

    return 0;
}



int main()
{
    //freopen("r.txt","r",stdin);
    while(cin>>n>>p)
    {
        for(int i=1;i<=n;i++)
        {
            cin>>b[i].number;
            b[i].postion=i;
        }
        sort(b+1,b+n+1,cmp);
        cou=0;
        for(int i=1;i<n;i++)
        {
            dep=i;
            if(dfs(0,1,0))break;
        }
        cout<<endl;
    }
    return 0;
}



 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值