HDU 1892 See you~

See you~

Time Limit: 5000/3000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 227 Accepted Submission(s): 79
 
Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year. 
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles. 
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position. 
 
Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed. 
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries. 
There are 4 kind of queries, sum, add, delete and move. 
For example: 
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points. 
A x1 y1 n1 means I put n1 books on the position (x1,y1) 
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them. 
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them. 
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100. 
 
Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries. 
For each "S" query, just print out the total number of books in that area. 
 
Sample Input
2
3
S 1 1 1 1
A 1 1 2
S 1 1 1 1
3
S 1 1 1 1
A 1 1 2
S 1 1 1 2
 
Sample Output
Case 1:
1
3
Case 2:
1
4
 
Author
题目大意:

给出平面内 n  多个 格子一开始每个格子赋值为 1  ,S  是查询  ( x, y)  到 ( x1,y1)  之间总和  ,A  是为   ( x, y)   加上  c    
D  是减去  M    是  将一个格子移动到另一个格子中   e  个。

思路:

二维树状数组就可以解决。注意树状数组从  1  开始

AC代码:

#include<iostream>
#include<cstring>
using namespace std;
#define N 1005
int C[N][N]; 
int sum(int x,int y) 
{
    int ret=0,i,j;
    for(i=x;i>0;i-=(i&-i))
        for(j=y;j>0;j-=(j&-j))
            ret+=C[i][j];
    return ret;
}
void add(int x,int y,int d) 
{
    int i,j;
   for(i=x;i<N;i+=(i&-i))
       for(j=y;j<N;j+=(j&-j))
           C[i][j]+=d;
}
int main()
{ 
    int t,n,a,b,c,d,e,i,j,k,v;
    char s[5];
    scanf("%d",&t);
    for(k=1;k<=t;++k)
    {
        scanf("%d",&n);
        printf("Case %d:\n",k);
        for(i=1;i<N;++i) 
        for(j=1;j<N;++j)
              C[i][j]=0;
       for(i=1;i<N;++i)
           for(j=1;j<N;++j)
              add(i,j,1);
        while(n--)
        {
            scanf("%s",s);
            if(s[0]=='S')
            {
                scanf("%d%d%d%d",&a,&b,&c,&d); 
                if(a<c) swap(a,c); 
                if(b<d) swap(b,d);
                printf("%d\n",sum(a+1,b+1)-sum(a+1,d)-sum(c,b+1)+sum(c,d));
            }
            else if(s[0]=='A')
            {
                scanf("%d%d%d",&a,&b,&c);
                add(a+1,b+1,c);
            }
            else if(s[0]=='D')
            {
                scanf("%d%d%d",&a,&b,&c);
                v=sum(a+1,b+1)-sum(a,b+1)-sum(a+1,b)+sum(a,b);
                c=v<c?v:c;
                add(a+1,b+1,-c);
            }
            else 
            {
                scanf("%d%d%d%d%d",&a,&b,&c,&d,&e);
                v=sum(a+1,b+1)-sum(a,b+1)-sum(a+1,b)+sum(a,b);
                e=v<e?v:e;
                add(a+1,b+1,-e);
                add(c+1,d+1,e);
            }        
        }
    }
    return 0;
}


 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值