HDU 1757 A Simple Math Problem

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 79 Accepted Submission(s): 65
 
Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 
Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 
Output

            For each case, output f(k) % m in one line.
 
Sample Input
10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0
 
Sample Output
45
104
 
Author
题目大意:

按照公式算出答案,题目给出的是  a0  .....  a9  

思路:

这里需要构造能够表示这个递推关系的矩阵,之前在  dp  那里做到过两个这种题目,矩阵一般都是和  dp  在一起的吧,用来加速运算这种。
这个矩阵构造起来也很简单。
f n            a0   a1  a2  a3   a4   a5   a6   a7   a8   a9   ^ n-9       9
f n-1         1    0    0    0    0     0     0     0    0     0                  8
f n-2         0     1    0    0    0     0     0     0    0     0                  7
f n-3  =     0     0    1    0    0     0     0     0    0     0                  6
..           0    0    0    1    0     0     0     0    0     0 * 5
f n-9  0   0    0    0    1     0     0     0    0     0 4
0    0    0    0   0     1     0     0    0 0 3
0    0    0    0    0     0     1     0    0     0 2
 0    0    0    0   0   0     0     1    0 0 1
0    0    0    0    0     0     0     0    1     0 0


AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int mod;
int n,k;
struct Matrix
{
    long long arr[12][12];
};

Matrix init,unit;

Matrix Mul(Matrix a,Matrix b)
{
    Matrix c;
    for(int i=0; i<10; i++)
        for(int j=0; j<10; j++)
        {
            c.arr[i][j]=0;
            for(int k=0; k<10; k++)
                c.arr[i][j]=(c.arr[i][j]+a.arr[i][k]*b.arr[k][j]%mod)%mod;
            c.arr[i][j]%=mod;
        }
    return c;
}

Matrix Pow(Matrix a,Matrix b,int x)
{
    while(x)
    {
        if(x&1)
        {
            b=Mul(b,a);
        }
        x>>=1;
        a=Mul(a,a);
    }
    return b;
}

int main()
{
    int atemp[10];
    while(~scanf("%d%d",&n,&mod))
    {
        for(int i=0;i<10;i++)
            scanf("%d",&atemp[i]);
        memset(init.arr,0,sizeof(init));
        memset(unit.arr,0,sizeof(unit));
        for(int i=0; i<10;i++)
        {
            init.arr[0][i]=atemp[i];
        }
        for(int i=1;i<10;i++)
        {
            init.arr[i][i-1]=1;
        }
        for(int i=0;i<10;i++)
        {
            unit.arr[i][0]=9-i;
        }
        Matrix res=Pow(init,init,n-10);
        long long int ans=0;
        for(int i=0;i<10;i++)
        {
            ans+=res.arr[0][i]*unit.arr[i][0];
        }
        printf("%d\n",ans%mod);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值