HDU 1914 The Stable Marriage Problem 稳定婚姻

The Stable Marriage Problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 56 Accepted Submission(s): 36
 
Problem Description
The stable marriage problem consists of matching members of two different sets according to the member’s preferences for the other set’s members. The input for our problem consists of:

a set M of n males;
a set F of n females;

for each male and female we have a list of all the members of the opposite gender in order of preference (from the most preferable to the least).
A marriage is a one-to-one mapping between males and females. A marriage is called stable, if there is no pair (m, f) such that f ∈ F prefers m ∈ M to her current partner and m prefers f over his current partner. The stable marriage A is called male-optimal if there is no other stable marriage B, where any male matches a female he prefers more than the one assigned in A.

Given preferable lists of males and females, you must find the male-optimal stable marriage.
 
Input
The first line gives you the number of tests. The first line of each test case contains integer n (0 < n < 27). Next line describes n male and n female names. Male name is a lowercase letter, female name is an upper-case letter. Then go n lines, that describe preferable lists for males. Next n lines describe preferable lists for females.
 
Output

            For each test case find and print the pairs of the stable marriage, which is male-optimal. The pairs in each test case must be printed in lexicographical order of their male names as shown in sample output. Output an empty line between test cases.
 
Sample Input
2
3
a b c A B C
a:BAC
b:BAC
c:ACB
A:acb
B:bac
C:cab
3
a b c A B C
a:ABC
b:ABC
c:BCA
A:bac
B:acb
C:abc
 
Sample Output
a A
b B
c C

a B
b A
c C
 
 
Source
题目大意:

给出  n  个男生,n 个女生,给出他们对异性的喜欢顺序,求一个稳定的婚姻组合。

思路:

看我上一篇同样的文章,一样的题目。

AC代码:

#include<stdio.h>
#include<string.h>
#include<string>
#include<map>
#include<iostream>
#include<algorithm>
#define maxn 555
#define clr(x)memset(x,0,sizeof(x))
using namespace std;
int tot;
int n;
int b[maxn][maxn];///男生 i 第 j  个喜欢的女生是几号
int g[maxn][maxn];///女生 i 对男生  j  的排名
int by[maxn],gl[maxn];  ///匹配情况
int r[maxn];
char s[30];
string bo[maxn],gi[maxn];///记录第 i  个男生或者女生的名字
int main()
{
    int bn,gn,t,flag,i,j,f;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        f=0;
        gn=1;
        clr(b);
        clr(g);
        for(i=1;i<=n;i++)
            r[i]=1;
        map<string,int>boy,girl;
          boy.clear(),girl.clear();
        for(i=1;i<=n;i++)
        {
            scanf("%s",&s);
            boy[s]=i;
            bo[i]=s;
        }
        for(i=1;i<=n;i++)
        {
            scanf("%s",&s);
            girl[s]=i;
            gi[i]=s;
        }
        tot=1;
        int tmpp;
        for(i=1;i<=n;i++)
        {
            scanf("%s",&s);
            for(j=2;j<=n+1;j++)
            {
                tmpp=s[j]-'A'+1;
                b[i][j-1]=tmpp;
            }
        }
        for(i=1;i<=n;i++)
        {
            scanf("%s",&s);
            for(j=2;j<=n+1;j++)
            {
                tmpp=s[j]-'a'+1;
                g[i][tmpp]=j-1;
            }
        }
        clr(by);  clr(gl);
        while(1)
        {
            flag=1;
            for(i=1;i<=n;i++)
                if(!by[i])
                {
                    t=b[i][r[i]++];///t 是 他喜欢的女生且他还没有匹配过
                    if(!gl[t])///如果这个女生刚好没对象,就结成一对
                    {
                        by[i]=t;
                        gl[t]=i;
                    }
                    else if(g[t][gl[t]]>g[t][i])///如果她有对象了,但是她更喜欢当前这个男生,则女生抛弃之前的男生和这个结成一对
                    {
                        by[gl[t]]=0;
                        gl[t]=i;
                        by[i]=t;
                    }
                    flag=0;
                }
            if(flag)
                break;
        }
        for(i=1;i<=n;i++)
            cout<<bo[i]<<' '<<gi[by[i]]<<endl;
        if(T)
            printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值