poj 2506 Tiling

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8943 Accepted: 4257

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

[Submit]   [Go Back]   [Status]   [Discuss]

公式为a[n]=a[n-1]+a[n-2]*2,但是我当时没推出来~,

我推出来的是:当i为偶数时a[i]=a[i-1]*2+1;当i为奇数时a[i]=a[i-1]*2-1;

然后用大数相加来写~

还有就是 这道题比较坑的地方吧:n可以为0,并且哪位0时 输出1种方式~~~

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f

int a[300][110];
int main()
{
    int n,i,index,j;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
        {
            printf("1\n");
            continue;
        }
        memset(a,0,sizeof(a));
        a[1][1]=1;
        for(i=2;i<=n;i++)
        {
            if(i%2==0)
            {
                for(j=1;j<110;j++)
                {
                   if(j==1)
                      a[i][j]=a[i][j]+a[i-1][j]*2+1;
                   else
                      a[i][j]=a[i][j]+a[i-1][j]*2;
                   if(a[i][j]>=10)
                   {
                       a[i][j+1]=a[i][j+1]+a[i][j]/10;
                       a[i][j]=a[i][j]%10;
                   }
                }
            }
            else
            {
                for(j=1;j<110;j++)
                {
                   if(j==1)
                      a[i][j]=a[i][j]+a[i-1][j]*2-1;
                   else
                      a[i][j]=a[i][j]+a[i-1][j]*2;
                   if(a[i][j]>=10)
                   {
                       a[i][j+1]=a[i][j+1]+a[i][j]/10;
                       a[i][j]=a[i][j]%10;
                   }
                }
            }
        }
        for(i=110;i>0;i--)
        {
            if(a[n][i]!=0)
            {
                index=i;
                break;
            }
        }
        for(i=index;i>=1;i--)
            printf("%d",a[n][i]);
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值