Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.
A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.
Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.
The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.
The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.
Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
Sample input:
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
Sample output:
5 1 5 2 4
- **
- * DFS核心伪代码
- * 前置条件是visit数组全部设置成false
- * @param n 当前开始搜索的节点
- * @param d 当前到达的深度,也即是路径长度
- * @return 是否有解
- */
- bool DFS(Node n, int d){
- if (d == 4){//路径长度为返回true,表示此次搜索有解
- return true;
- }
- for (Node nextNode in n){//遍历跟节点n相邻的节点nextNode,
- if (!visit[nextNode]){//未访问过的节点才能继续搜索
- //例如搜索到V1了,那么V1要设置成已访问
- visit[nextNode] = true;
- //接下来要从V1开始继续访问了,路径长度当然要加
- if (DFS(nextNode, d+1)){//如果搜索出有解
- //例如到了V6,找到解了,你必须一层一层递归的告诉上层已经找到解
- return true;
- }
- //重新设置成未访问,因为它有可能出现在下一次搜索的别的路径中
- visit[nextNode] = false;
- }
- //到这里,发现本次搜索还没找到解,那就要从当前节点的下一个节点开始搜索。
- }
- return false;//本次搜索无解
- }
#include <iostream>
#include <algorithm>
using namespace std;
char ori[99][99];//其实只用开到5就可以了,但我刚看题的时候没有注意到最大只到4.。。。。。
char pro[99][99];
int ans=0;//最终的答案
int n;
int cnt=0;//每一种情况下炮塔的个数
bool f(int k)//用来判断此处是否可以放炮塔
{
//这里用了比较傻的办法,将其分成四个方向,厉害的大神可以用%的方法,可以把四个循环缩减到两个
//k代表的是第几个格子,k/n即为这个格子的行数,k%n为列数
for(int i=k/n-1;i>=0;i--)
{
if(pro[i][k%n]=='X')//如果到墙就结束
break;
if(pro[i][k%n]=='0')//如果有炮塔在这条线上就返回false
return false;
}
for(int i=k/n+1;i<n;i++)
{
if(pro[i][k%n]=='X')
break;
if(pro[i][k%n]=='0')
return false;
}
for(int i=k%n-1;i>=0;i--)
{
if(pro[k/n][i]=='X')
break;
if(pro[k/n][i]=='0')
return false;
}
for(int i=k%n+1;i<n;i++)
{
if(pro[k/n][i]=='X')
break;
if(pro[k/n][i]=='0')
return false;
}
return true;
}
void DFS(int k)
{
for(int i=k;i<n*n;i++)
{
if(pro[i/n][i%n]=='.'&&f(i))//判断是否已经放过
{
pro[i/n][i%n]='0';
cnt++;
DFS(k+1);//开始看下一个格子的情况
if(cnt>ans)ans=cnt;//到这里一种情况就已经结束,就要判断这种情况下炮塔是不是最多的
pro[i/n][i%n]='.';//代表着这个位置不放,例如DFS(0)(有放炮塔)这个分支结束时,开始第二个分支DFS(0)(没放炮塔)
cnt--;//对应的次数也要减1
}
}
}
int main()
{
while(cin>>n&&n)
{
ans=0;cnt=0;
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
{
cin>>pro[i][j];
}
DFS(0);
cout<<ans<<endl;
}
return 0;
}