Catch That Cow

Catch That Cow

Time Limit: 2000MS Memory limit: 65536K

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4

提示

poj3278 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。 
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

示例程序

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int n, k;
int que[100010];
int book[100010];
int has(int i)
{
    if(i<0 || i>100000||book[i]){
        return 0;
    }else {
        return 1;
    }
}
int bfs(int n,int k)
{
    if(n == k) return 0;
    int head = 0;
    int tail = 1;
    que[head] = n;
    int x;
    while(head < tail){
        x = que[head];
        head++;
        if(x+1==k || x-1==k || x*2 == k){
            return book[x]+1;
        }
        if(has(x-1)){
            book[x-1] = book[x]+1;
            que[tail++] = x-1;
        }
        if(has(x+1)){
            book[x+1] = book[x]+1;
            que[tail++] = x+1;
        }
        if(has(x*2)){
            book[x*2] = book[x]+1;
            que[tail++] = x*2;
        }
    }

    return -1;
}
int main()
{
    while(~scanf("%d %d", &n, &k)){
        memset(book,0,sizeof(book));
        memset(que,0,sizeof(que));
        printf("%d\n", bfs(n,k));
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值