A1002 A+B for Polynomials (25) [模拟]

A1002 A+B for Polynomials (25) [模拟]

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 aN1 N2 aN2 … NK aNK

where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题目大意:

  • 给出两行,每行表示一个多项式,第一个数表示非零项的项数,后面相邻的每两个数表示一项,分别为该项的幂次和系数。
  • 求出多项式的和以相同格式输出

思路分析:

  • 设立c数组,长度为指数的最大值,c[i] = j表示指数i的系数为j,接收a和b输入的同时将对应指数

    的系数加入到c中,累计c中所有非零系数的个数,然后从后往前输出所有系数不为0的指数和系数

代码实现:

#include <iostream>
using namespace std;
int main() {
	float c[1001] = {0};
	int m, n, t;
	float num;
	scanf("%d", &m);
	for (int i = 0; i < m; i++) {
		scanf("%d%f", &t, &num);
		c[t] += num;
 	}
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		scanf("%d%f", &t, &num);
		c[t] += num;
 	}
	int cnt = 0;
	for (int i = 0; i < 1001; i++) {
		if (c[i] != 0) cnt++;
 	}
	printf("%d", cnt);
	for (int i = 1000; i >= 0; i--) {
		if (c[i] != 0.0)
		printf(" %d %.1f", i, c[i]);
 	}
	return 0; 
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值