POJ1013解题报告

问题描述:

Counterfeit Dollar
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 48963
Accepted: 15461

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

解题思路:

本题的问题描述为,有12个硬币,其中一枚硬币是假币,不知轻重。与常规的智力题不同的是,这里是给出了三次称量的结果,每次分别为:左天平硬币标号-右天平硬币标号-称量结果。根据这个结果,要求你找出假币并判断出假币比真币轻还是重。

这个问题很简单,硬币一共只有12枚,结果也只有两种,要么比真币轻,要么比真币重,那么一共最多只有12*2=24种情况,我们进行枚举,一一试探,看是否符合输入的条件即可


代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<string.h>
using namespace std;
char Right[3][7];
char Left[3][7];
char Result[3][7];
bool IsFake(char c,bool light);

int main()
{
	int t; 
	cin>>t;
	while(t--)
	{
		for(int i=0;i<3;i++)
		{
			cin>>Left[i]>>Right[i]>>Result[i];
		}
		for(char c='A';c<='L';c++)
		{
			if(IsFake(c,true))
			{
				cout<<c<<" is the counterfeit coin and it is light. "<<endl;
				break;
			}
			else if(IsFake(c,false))
			{
				cout<<c<<" is the counterfeit coin and it is heavy. "<<endl;
				break;
			}
		}
	}
	return 0;
}

bool IsFake(char c,bool light)
{
	char *pleft,*pright,*presult;
	for(int i=0;i<3;i++)
	{
		if(light)
		{
			pleft=Left[i];
			pright=Right[i];
		}
		else
		{
			pleft=Right[i];
			pright=Left[i];
		}
		switch(Result[i][0])
		{
			case 'u':if(strchr(pright,c)==NULL)
						return false;
					break;
			case 'e':if(strchr(pleft,c) || strchr(pright,c))
						return false;
					break;
			case 'd':if(strchr(pleft,c)==NULL)
						return false;
					break;
		}
	}
	return true;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ1753题目为"Flip Game",题目给出了一个4x4的棋盘,每个格子有黑色或白色,每次翻转一个格子会同时翻转它上下左右四个格子的颜色,目标是把整个棋盘都变为同一种颜色,求把棋盘变成同种颜色的最小步数。 解题思路: 一般关于棋盘变色的题目,可以考虑使用搜索来解决。对于POJ1753题目,可以使用广度优先搜索(BFS)来解决。 首先,对于每个格子,定义一个状态,0表示当前格子是白色,1表示当前格子是黑色。 然后,我们可以把棋盘抽象成一个长度为16的二进制数,将所有格子的状态按照从左往右,从上往下的顺序排列,就可以用一个16位的二进制数表示整个棋盘的状态。例如,一个棋盘状态为: 0101 1010 0101 1010 则按照从左往右,从上往下的顺序把所有格子的状态连接起来,即可得到该棋盘的状态为"0101101001011010"。 接着,我们可以使用队列来实现广度优先搜索。首先将初始状态加入队列中,然后对于队列中的每一个状态,我们都尝试将棋盘上的每个格子翻转一次,生成一个新状态,将新状态加入队列中。对于每一个新状态,我们也需要记录它是从哪个状态翻转得到的,以便在得到最终状态时能够输出路径。 在搜索过程中,我们需要维护每个状态离初始状态的步数,即将该状态转换为最终状态需要的最小步数。如果我们找到了最终状态,就可以输出答案,即最小步数。 代码实现:

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值