PATA 1064 Complete Binary Search Tree(30 分)解题报告

1064 Complete Binary Search Tree(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

 

题目大意:给你一个序列,所有的数都非负且不同,然后要求你用这个序列建一个完全二叉搜索树,再给出这个树的层序序列。

解题思路:我们知道,二叉搜索树的中序序列是有序的,那么我们把输入的序列进行排序,就得到了这棵BST的中序序列,我们再按中序遍历的方式建树,就得到了这棵完全二叉搜索树,因为是完全二叉树,所以可以用一个数组来保存,且有n个结点,就一定会把前面n个空间占满。最后输出层序序列的时候,在vector中从头到尾输出就是层序序列,因为在类array结构中存储树,总是把根节点存储在第一个,子树的根节点必然也是在子树之前。

 

AC代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<queue>
#include<stack>
#include<algorithm> 
#include<cmath>
using namespace std;
const int maxn=1010;
int number[maxn],CBT[maxn],n,index=0;
void inorder(int root);
int main()
{
	cin>>n;
	for(int i=0;i<n;i++)
		cin>>number[i];
	sort(number,number+n);//排序得到中序序列 
	inorder(1);//按照中序序列建树 
	for(int i=1;i<=n;i++)//层序输出 
	{
		cout<<CBT[i];
		if(i<n)
			cout<<" ";
	}
	return 0;
}

void inorder(int root)
{
	if(root>n)
		return;
	inorder(2*root);
	CBT[root]=number[index++];
	inorder(2*root+1);
}

 

  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值