PATA 1098 Insertion or Heap Sort(25 分)解题报告

1098 Insertion or Heap Sort(25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

 

题目大意:给定一个初始序列,然后给定一个中间序列,要求你判断这个中间序列是由堆排序得到的还是由插入排序得到的。

并输出下一步排序的结果

解题思路:写出两种排序方法,并在排序每进行一步的时候进行判断,如果得到了中间序列,就再进行一次排序,然后输出当前序列,退出排序。记住中间序列并不包括初始序列,所以在判断时要对是否已经进行过至少一趟排序有判断。此外应该在每趟排序开始之前进行序列匹配的判断,这样得到匹配成功结果之后可以直接再进行一次排序,然后输出

本题考察插入排序和堆排序的写法

 

AC代码:

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=110;
int ori[maxn],tempori[maxn],changed[maxn];//原始数组,原始备份数组,目标数组
int n;//元素个数
bool isSame(int a[],int b[]);//判断数组是否相同 
bool print(int a[]);//输出数组
bool insertSort();//插入排序
void downAdjust(int low,int high);//向下调整堆
void heapSort();//堆排序
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&ori[i]);
		tempori[i]=ori[i];
	}
	for(int i=1;i<=n;i++)
		scanf("%d",&changed[i]);//读入目标数组
	if(insertSort())
	{
		printf("Insertion Sort\n");
		print(tempori);
	}
	else
	{
		printf("Heap Sort\n");
		for(int i=1;i<=n;i++)
			tempori[i]=ori[i];
		heapSort();
	}
	return 0;
}

bool isSame(int a[],int b[])
{
	for(int i=1;i<=n;i++)
		if(a[i]!=b[i])
			return false;
	return true; 
}

bool print(int a[])
{
	for(int i=1;i<=n;i++)
	{
		printf("%d",a[i]);
		if(i<n) printf(" ");
	}
	printf("\n");
}

bool insertSort()
{
	bool flag=false;
	for(int i=2;i<=n;i++)//n-1趟插入排序
	{
		if(i!=2&&isSame(tempori,changed))
			flag=true;
		sort(tempori,tempori+i+1);//用sort代替insertionsort插入步骤
		if(flag==true)
			return true;
	}
	return false;
}

void downAdjust(int low,int high)//向下调整,O(logN) 
{
	int i=low,j=i*2;//i为欲调整结点,j为其左孩子
	while(j<=high)//存在孩子结点 
	{
		if(j+1<=high&&tempori[j+1]>tempori[j])//如果右孩子存在且右孩子的值大于左孩子 
			j=j+1;//让j存储右孩子下标 
		if(tempori[j]>tempori[i])//孩子中最大的那个比要调整的结点i大
		{
			swap(tempori[j],tempori[i]);//交换二者
			i=j;//始终保持i为需要调整的结点,j为i的孩子 
			j=i*2;
		}
		else break;//孩子结点权值均比欲调整结点i要小,调整结束
	}
}

void heapSort()
{
	bool flag=false;
	for(int i=n/2;i>=1;i--)
		downAdjust(i,n);	//建堆
	for(int i=n;i>1;i--)
	{
		if(i!=n&&isSame(tempori,changed))
			flag=true;
		swap(tempori[i],tempori[1]);
		downAdjust(1,i-1);
		if(flag==true)
		{
			print(tempori);
			return;
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值