poj 3264RMQ

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

这道题是自己做的第一道RMQ题,RMQ算法不难理解,但其中有很多细节需要牢固记忆。

1. 进行RMQ时,区间长度 j ,for(j=1;(1<<j)<=N;++j )

2.进行RMQ时,下标 i ,for(int i=0;i+(1<<j)-1<N;++i)

3.不要忘记求区间范围时,给左右边界同时-1,以转换为下标。

4.最后多做简单的优化,如可以不用赋初值时,不用memset 优化,可以减少一半的时间消耗

#include<stdio.h>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<math.h>

using namespace std;
const int inf = 0x3f3f3f3f;
int high[50010];
int Rmq[50010][20];
int rmq[50010][20];
int N, Q;

void RMQ()
{
	for (int i = 0; i < N; ++i)
	{
		rmq[i][0] = high[i];
		Rmq[i][0] = high[i];
	}
	for (int j = 1; (1 << j) <= N; ++j)
	{
		for (int i = 0; i + (1 << j) - 1 < N; ++i)
		{
			Rmq[i][j] = max(Rmq[i][j - 1], Rmq[i + (1 << (j - 1))][j - 1]);
			rmq[i][j] = min(rmq[i][j - 1], rmq[i + (1 << (j - 1))][j - 1]);
		}
	}
}
void query(int a, int b)
{
	int k = log(b - a + 1.0) / log(2.0);//log里为小数
	a--;
	b--;
	int maxx = max(Rmq[a][k], Rmq[b - (1 << k) + 1][k]);
	//不可写为 max(Rmq[a][k], Rmq[a+ (1 << k) + 1][k]);因为可能会超越b这个界限,不妨换个方式,最多重叠部分
	int minn = min(rmq[a][k], rmq[b - (1 << k) + 1][k]);
	cout << maxx - minn << endl;
}
int main()
{
	//freopen("in.txt","r",stdin);
	while (cin >> N >> Q)
	{
		for (int i = 0; i < N; ++i)
			cin >> high[i];
		memset(rmq, inf, sizeof(rmq));
		memset(Rmq, -inf, sizeof(Rmq));
		RMQ();
		for (int j = 1; j <= Q; ++j)
		{
			int a, b;
			cin >> a >> b;
			query(a, b);
		}
	}
	return 0;
	//system("pause");
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值