STL栈 - 火车进出栈

火车进出栈

时间限制: 1 Sec  内存限制: 128 MB

题目描述

As the new term comes, the Train Station is very busy nowadays. A lot of student want to get back to school by train. But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

输入

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

输出

The output contains a string "No" if you can't exchange O2 to O1, or you should output a line contains "Yes".

样例输入

3 123 321
3 123 312

样例输出

Yes
No

提示

For the first Sample Input, we let train 1 get in, then train 2 and train 3.

So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.

In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.

Now we can let train 3 leave.

But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.

So we output "No".


#include<cstdio>
#include<cmath>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<queue>
#include<stack>
#include<set>
#include<list>
 
using namespace std;
 
 
int main()
{
    int n;
    string a, b;
    while (cin >> n >> a >> b)
    {
        stack<char> s;
        int x=0, y=0;
        int ok = 1;
        while (y < n)
        {
            if (a[x] == b[y]) { x++; y++; }
            else if (!s.empty() && s.top() == b[y]) { s.pop(); y++; }
            else if (x < n)s.push(a[x++]);
            else { ok = 0; break; }
        }
        printf("%s\n", ok ? "Yes" : "No");
    }
    return 0;
}


【隔的时间有点久不记得是不是自己完成的了,应该有【大部分?】借鉴《算法竞赛入门经典》吧。。。。。】

一个栈混洗的问题恩对


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值