HDU 4027

Can you answer these queries?
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 16115 Accepted Submission(s): 3769

Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6

题意:
n个数,两种操作:0 b c表示将[b,c]区间的数开方,1 b c表示询问[b,c]区间的和。

代码:

#include<bits/stdc++.h>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxn 100015
long long tree[maxn<<2];

void push_up(long long rt)
{
    tree[rt]=tree[rt<<1]+tree[rt<<1|1];
}

void build(long long l,long long r,long long rt)
{
    if(l==r)
        scanf("%lld",&tree[rt]);
    else {
        long long m=(l+r)>>1;
        build(lson);
        build(rson);
        push_up(rt);
    }
}

void update(long long L,long long R,long long l,long long r,long long rt)
{
    if(l==r)
    {
        tree[rt]=sqrt(tree[rt]);
        return;
    }
    if(L<=l&&R>=r&&tree[rt]==r-l+1) return;
    long long m=(l+r)>>1;
    if(L<=m) update(L,R,lson);
    if(m<R) update(L,R,rson);
    push_up(rt);
}

long long query(long long L,long long R,long long l,long long r,long long rt)
{
    if(L<=l&&r<=R)
        return tree[rt];
    else {
        long long m=(l+r)>>1;
        long long ans=0;
        if(L<=m) ans+=query(L,R,lson);
        if(m<R) ans+=query(L,R,rson);
        return ans;
    }
}

int main()
{
    long long n,m;
    long long ci=0;
    while(~scanf("%lld",&n))
    {
        build(1,n,1);
        scanf("%lld",&m);
        printf("Case #%lld:\n",++ci);
        long long a,b,c;
        for(long long i=0;i<m;i++)
        {
            scanf("%lld%lld%lld",&a,&b,&c);
            int bb=min(b,c),cc=max(b,c);
            if(a) cout<<query(bb,cc,1,n,1)<<endl;
            else update(bb,cc,1,n,1);
        }
        cout<<endl;
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值