HDU - 1525 博弈

14 篇文章 0 订阅
11 篇文章 0 订阅

Euclid’s Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3584 Accepted Submission(s): 1686

Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input
34 12
15 24
0 0

Sample Output
Stan wins
Ollie wins

Source
University of Waterloo Local Contest 2002.09.28

Recommend
LL

首先很显然可以看出来当先手面对局面中有1或0(开局有0)的就必胜了,然后对于比较复杂的情况,其实只有两种情况:
1.先手没有选择,必须把局面从(n,m)转为(m,n%m),也就是说n/m<2
2.先手有选择,也就是说n/m>=2,这个时候其实先手已经赢了,因为如果(m,n%m)是可以赢的,他就让自己转移过去,否则让后手面临情况1即可。

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,m;

    while(~scanf("%d%d",&n,&m)&&(n+m)) {
        bool flag=true;
      if(n<m) swap(n,m);
      while(m>=2&&n%m&&n/m<2)
      {
          int z=n;
          n=m;
          m=z-m;
          flag=!flag;
      }
      if(flag) cout<<"Stan wins"<<endl;
      else cout<<"Ollie wins"<<endl;
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值