poj 1562 Oil Deposits

2 篇文章 0 订阅

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source

Mid-Central USA 1997

这道题是一道非常基础的搜索题目,适合初学者加以练习,也是本人AC的第一道搜索题。当时用的DFS,注意本题是多组测试数据。

/*
Problem: 1562  User: saruka 
Memory: 188K  Time: 0MS 
Language: C++  Result: Accepted 
*/
#include<cstdio>
#include<cstring>
using namespace std;
int n, m;
const int maxn = 105;
char graph[maxn][maxn];
bool vis[maxn][maxn];
const int dx[8] = {-1, 1, 0, 0, -1, 1, -1, 1};
const int dy[8] = {0, 0, -1, 1, -1, -1, 1, 1};
int xx, yy, sum = 0;
void dfs(int x, int y)
{
    vis[x][y] = true;
    for(int i = 0; i < 8; i++)
    {
        xx = x + dx[i];
        yy = y + dy[i];
        if(xx < 0 || yy < 0 || xx >= n || yy >= m) continue;
        if(graph[xx][yy] == '@' && !vis[xx][yy])
        {
            dfs(xx, yy);
        }
    }
}
int main()
{
    while(scanf("%d%d", &n, &m) == 2 && (n > 0))
    {
        sum = 0;
        memset(vis, 0, sizeof(vis));
        memset(graph, 0, sizeof(graph));
        for(int i = 0; i < n; i++)
        {
            scanf("%s", graph[i]);
        }
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                if(graph[i][j] == '@' && !vis[i][j])
                {
                    dfs(i, j);
                    sum++;
                }
            }
        }
        printf("%d\n", sum);
    }
    return 0;
}

Powered By Saruka.
Copyright © 2016 All Rights Reserved.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值