较难DP(1227)

Fast Food

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2584    Accepted Submission(s): 1101


Problem Description
The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as



must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized.
 

Input
The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed.
 

Output
For each chain, first output the number of the chain. Then output a line containing the total distance sum.

Output a blank line after each test case.
 

Sample Input
  
  
6 3 5 6 12 19 20 27 0 0
 

Sample Output
  
  
Chain 1 Total distance sum = 8

此题首先需要一个常识:在连续的点中间建立一个能使距离和最短的点时,那个点的序号必然是(i+j)/2。状态比较难设计:设dp[i][j]为前j个商店建i个仓库,则dp方程是:dp[i][j]=min(dp[i][j],dp[i-1][m]+case[m+1][j]) (i-1<=m<=j-1) 。含义就是遍历m,注意m的区间范围,仓库数必然-1,商店数不确定,需要从i-1到j-1枚举,case数组的含义是从商店m+1到j的最小贡献(即用之前结论),即将原线段分成了两段

/*------------------Header Files------------------*/
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#include <ctype.h>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#include <vector>
#include <limits.h>
using namespace std;
/*------------------Definitions-------------------*/
#define LL long long
#define PI acos(-1.0)
#define INF 0x3F3F3F3F
#define MOD 10E9+7
#define MAX 500050
/*---------------------Work-----------------------*/
int dis[250],cost[250][250];
int dp[35][250];
void work()
{
	int n,k,Case=1;
	while(scanf("%d%d",&n,&k))
	{
		if(n==0&&k==0) break;
		for(int i=1;i<=n;i++)
			scanf("%d",dis+i);
		memset(cost,0,sizeof(cost));
		for(int i=1;i<=n-1;i++)
		{
			for(int j=i;j<=n;j++)
			{
				int mid=(i+j)/2;
				for(int k=i;k<=j;k++)
					cost[i][j]+=abs(dis[mid]-dis[k]);
			}
		}
		memset(dp,0x3F,sizeof(dp));
		for(int i=1;i<=n;i++) //注意初始化 
			dp[1][i]=cost[1][i];
		for(int i=2;i<=k;i++)
		{
			for(int j=i;j<=n;j++)
			{
				for(int m=i-1;m<=j-1;m++)
					dp[i][j]=min(dp[i][j],dp[i-1][m]+cost[m+1][j]);
			}
		}
		printf("Chain %d\n",Case++);
		printf("Total distance sum = %d\n\n",dp[k][n]);
	}
}
/*------------------Main Function------------------*/
int main()
{
	//freopen("test.txt","r",stdin);
	//freopen("cowtour.out","w",stdout);
	//freopen("cowtour.in","r",stdin);
	work();
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值