带权并查集(1856)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 25846    Accepted Submission(s): 9278


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
 
 
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int pre[10000050];
int Rank[10000050];
int maxn;

int find(int x)
{
    if(pre[x]==x) return x;
    else return pre[x]=find(pre[x]);
}

void join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx==fy) return ;
    if(fx<fy) pre[fy]=fx,Rank[fx]+=Rank[fy],maxn=max(maxn,Rank[fx]); //将比较运算放在这里,提高效率
    else pre[fx]=fy,Rank[fy]+=Rank[fx],maxn=max(maxn,Rank[fy]);
}

int main()
{
    //freopen("input.txt","r",stdin);
    int n;
    while(scanf("%d",&n)==1)
    {
        if(n==0) //注意这个特例
        {
            printf("1\n");
            continue;
        }

        for(int i=1;i<=10000000;i++)
            pre[i]=i,Rank[i]=1;
        maxn=-1;

        int a,b;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a,&b);
            join(a,b);
        }
        printf("%d\n",maxn);
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
权并查集(Weighted Union-Find)是一种常用的数据结构,用于解决动态连通性问题。它支持两个主要操作:合并(Union)和查找(Find)。 以下是一个使用Python实现的权并查集示例代码: ```python class WeightedUnionFind: def __init__(self, n): self.parent = list(range(n)) self.size = [1] * n self.weight = [0] * n def find(self, x): if self.parent[x] != x: self.compress_path(x) return self.parent[x] def union(self, x, y, w): root_x = self.find(x) root_y = self.find(y) if root_x == root_y: return if self.size[root_x] < self.size[root_y]: self.parent[root_x] = root_y self.weight[root_x] = w - self.weight[x] + self.weight[y] self.size[root_y] += self.size[root_x] else: self.parent[root_y] = root_x self.weight[root_y] = -w + self.weight[x] - self.weight[y] self.size[root_x] += self.size[root_y] def compress_path(self, x): if self.parent[x] != x: self.compress_path(self.parent[x]) self.weight[x] += self.weight[self.parent[x]] self.parent[x] = self.parent[self.parent[x]] def get_weight(self, x): root = self.find(x) return self.weight[x] - self.weight[root] ``` 这个实现中,`parent`列表存储每个元素的父节点索引,`size`列表存储每个元素所在集合的大小,`weight`列表存储每个元素与其父节点的权值差。 `find()`方法用于查找元素所属的集合,并进行路径压缩优化。`union()`方法用于合并两个集合,并更新权值差。`compress_path()`方法用于路径压缩,加速后续的查找操作。`get_weight()`方法用于获取元素与其根节点的权值差。 权并查集可以在解决一些算法问题中起到很好的作用,例如最小生成树算法中的Kruskal算法。希望这个示例代码能对你有所帮助!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值