两个费用的贪心(HDOJ 4864)

Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7328    Accepted Submission(s): 1939


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
  
  
1 2 100 3 100 2 100 1
 

Sample Output
  
  
1 50004
 

Author
FZU
 

Source


// test.cpp : Defines the entry point for the console application.
//

// #include "stdafx.h"
#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>

using namespace std;

int n, m;
int cnt[100050];

struct node
{
	int x, y;
}ma[100050], ta[100050];

bool cmp(node a, node b)
{
	if (a.x != b.x) return a.x > b.x;
	else return a.y > b.y;
}

int main()
{
	while (scanf("%d%d", &n, &m) == 2)
	{
		for (int i = 1; i <= n; i++)
			scanf("%d%d", &ma[i].x, &ma[i].y);
		for (int i = 1; i <= m; i++)
			scanf("%d%d", &ta[i].x, &ta[i].y);
		sort(ma + 1, ma + n + 1, cmp);
		sort(ta + 1, ta + m + 1, cmp);

		memset(cnt, 0, sizeof(cnt));
		int j = 1;
		int num = 0;
		long long sum = 0;
		for (int i = 1; i <= m; i++) // 用任务匹配机器,而不是机器去匹配任务;同时贪心方式决定了总金额最优
		{
			while (j <= n && ma[j].x >= ta[i].x) // j一直后移,因为满足前面任务的必定满足后面任务(前面任务时间更长)
			{
				cnt[ma[j].y]++; // 将cnt数组自增,代表此难度的机器增加一个
				j++;
			}
			for (int k = ta[i].y; k <= 100; k++) // 贪心选择一个满足条件的难度最小的
			{
				if (cnt[k])
				{
					num++;
					cnt[k]--; // 此难度的一个机器被使用了
					sum += 500 * ta[i].x + 2 * ta[i].y;
					break;
				}
			}
		}
		printf("%d %I64d\n", num, sum);
	}
    return 0;
}

  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值