1019 数字黑洞

给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174,这个神奇的数字也叫 Kaprekar 常数。

例如,我们从6767开始,将得到

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。

输入格式:

输入给出一个 (0,104) 区间内的正整数 N。

输出格式:

如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000;否则将计算的每一步在一行内输出,直到 6174 作为差出现,输出格式见样例。注意每个数字按 4 位数格式输出。

输入样例 1:

6767

输出样例 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

输入样例 2:

2222

输出样例 2:

2222 - 2222 = 0000

 代码实现

第一个实现,有一项测试点不满足,我还没找出来哪里的问题,第二个solution参考了其他人写的,第二个全部AC了的,两种实现方式大同小异

solution1
#include<iostream>
#include<string>
#include<algorithm>
#include<iomanip>
using namespace std;
int main(){
    int n;
    cin>>n;
    string fdz,fdj,tmp;
    int nextN=n;
    while(1){       
        
        tmp=to_string(nextN);
        while(tmp.size()<=3){
            tmp.insert(0,"0");
        }
        sort(tmp.begin(),tmp.end(),greater<char>());
        fdz=tmp;
        sort(tmp.begin(),tmp.end());
        fdj=tmp;
        nextN=stoi(fdz)-stoi(fdj);

        if(fdz==fdj){
            cout<<fdz<<" - "<<fdj<<" = 0000";
            break;
        }
        cout<<fdz<<" - "<<fdj<<" = "<<setw(4)<<nextN<<endl;
        if(nextN==6174)
            break;
              
    }
    return 0;
}

 solution2

#include<bits/stdc++.h>
using namespace std;
int main(){
    // a为被减数,b为减数,temp为结果
    string a,b,temp;
    cin>>a;
    while(1){
        //当位数不足4位时,在前面补0
        while(a.size()<4) a='0'+a;
        //从小到大排序,那么排序后的结果就是减数b
        sort(a.begin(),a.end());
        b=a;
        //翻转后的结果就是最大的数,即被减数a
        reverse(a.begin(),a.end());
        //要计算结果时,必须要先把被减数和减数转化为int型,才能计算
        int a1=stoi(a);
        int b1=stoi(b);
        //将int型转化为string型
        temp=to_string(a1-b1);
        //当结果位数不足4位时,补0
        while(temp.size()<4) temp='0'+temp;
        cout<<a<<" - "<<b<<" = "<<temp<<endl;
        if(temp=="0000") break;
        if(temp=="6174") break;
        a=temp;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值