1099. Build A Binary Search Tree (30)

1099. Build A Binary Search Tree (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.


Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:

58 25 82 11 38 67 45 73 42


题意就是输入节点从0-n-1的字孩子节点序号按前序遍历的顺序来 -1就是空 然后再输入一串数列 输出这串数列在这棵BST中的唯一层序遍历序列


由于我BST的形状已经确定了    所以就不能任意插入点的值  那么我们分析过后会发现 由于我的BST形状是由前序遍历确定的  节点左边的树都是小于该节点的节点

节点右边的树都是大于该节点的节点 那么既然结构已经确定   也就是说明该BST的每个点有多少个点比他自己小 就确定了 

我们已知的就是BST 的前序序列是一个递增序列 也就是说   那么我们把输入的序列排序 然后在按照大小关系填入bst中不就行了

那我们最后就发现 其实就是bst的前序遍历序列按照前序遍历的顺序把递增数列一一填进去在广搜输出就可以了

code:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
	int l,r,d;
}nod[110];
int a[110],ind;
void inorder(int rt)
{
	if(rt!=-1)
	{
		inorder(nod[rt].l);
		nod[rt].d=a[ind++];
		inorder(nod[rt].r);		
	}
}
void leveltre(int rt)
{
	queue<int>q;
	q.push(rt);
	bool flag=1;
	while(q.size())
	{
		int a=q.front();q.pop();
		if(flag){
			printf("%d",nod[a].d);flag=0;
		}	
		else printf(" %d",nod[a].d);
		if(nod[a].l!=-1)q.push(nod[a].l);
		if(nod[a].r!=-1)q.push(nod[a].r);
	}
}
int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
		cin>>nod[i].l>>nod[i].r;
	

	for(int i=0;i<n;i++)
		cin>>a[i];
	
	sort(a,a+n);
	inorder(0);

	leveltre(0);
	return 0;
}

还有指针实现 一直过不了所有的样例 不知道为何 有看出来的大神可以帮我指下哪里出错了么?

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;
typedef struct node
{
	int no;
	int data;
	node *ls,*rs;
}NN,*NNN;
int fb,cpy,a[110];
void build(NNN rt)
{
	if(rt==NULL||cpy==0)return;
	int l,r;
	cin>>l>>r;
	cpy--;
	if(l!=-1)
	{
		NNN p = (NNN)malloc(sizeof(node));
		p->no=l;
		p->data=0;
		p->ls=p->rs=NULL;
		rt->ls=p;
	}
	if(r!=-1)
	{
		NNN p = (NNN)malloc(sizeof(node));
		p->no=r;
		p->data=0;
		p->ls=p->rs=NULL;
		rt->rs=p;
	}
	build(rt->ls);
	build(rt->rs);
}
void levelTre(NNN rt)
{
	queue<NNN>q;
	q.push(rt);
	while(q.size())
	{
		NNN a;
		a=q.front();q.pop();
		printf("%d",a->data);
		if(a->ls)q.push(a->ls);
		if(a->rs)q.push(a->rs);
		if(q.size())printf(" ");
	}
}
void findNum(NNN rt)
{
	if(rt)
	{
		findNum(rt->ls);
		rt->data=a[fb++];
		findNum(rt->rs);	
	}
}
int main()
{
	int n;
	cin>>n;
	cpy=n;
	node rt;
	rt.no=0;
	rt.data=0;
	rt.ls=rt.rs=NULL;
	
	build(&rt);
	for(int i=1;i<=n;i++)scanf("%d",&a[i]);
	
	sort(a+1,a+1+n);
	fb=1;
	findNum(&rt);
	levelTre(&rt);
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值