PAT-1127. ZigZagging on a Tree (30)

1127. ZigZagging on a Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.


Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:

1 11 5 8 17 12 20 15



题意就是要按照给定的中序遍历和后续遍历顺序输出树的蛇形遍历序列 


我们可以先还原出树 然后在把树dfs一遍 推出每层的节点有多少  记录下来 在用一个bfs搞出层序遍历存到vector里

 然后再根据每层的节点数  把vector里响应的元素reverse!


CODE:

#include<bits/stdc++.h>
#include<vector>
using namespace std;
int in[35];
int post[35];
int flo[30];
typedef struct node
{
	int key;
	node *l,*r;
	node(int k):key(k),l(NULL),r(NULL){}
}NN,*NNN;
NNN devide(int l,int r,int pl,int pr)
{
	int i,k=post[pr],left,right;
	for(i=l;in[i]!=k&&i<=r;i++);//lack ;
	left = i-l;
	right = r-i;
	NNN p = (NNN)malloc(sizeof(NN));
	p->key=k;p->l=p->r=NULL;
	if(right!=0)p->r=devide(i+1,r,pr-right,pr-1);
	if(left!=0)p->l=devide(l,i-1,pl,pr-right-1);
	return p;
}

void preorder(NNN p)
{
	if(p)
	{
		printf("%d ",p->key);
		preorder(p->l);
		preorder(p->r);
	}
}
int flor;
void dfs(NNN rt,int f)
{
	if(rt)
	{
		flo[f]++;
		dfs(rt->l,f+1);
		dfs(rt->r,f+1);
		flor=max(flor,f);
	}
}
vector<int>res;
void bfs(NNN rt)
{
	queue<NNN>q;
	q.push(rt);
	while(q.size()) 
	{
		NNN a = q.front();q.pop();
		int t = a->key;
		res.push_back(t);
		if(a->l!=NULL)q.push(a->l);
		if(a->r!=NULL)q.push(a->r);
	}
} 
int main()
{
	int n;
	cin>>n;
	for(int i=1;i<=n;i++)scanf("%d",&in[i]);
	for(int i=1;i<=n;i++)scanf("%d",&post[i]);
	NNN rt;
	rt=devide(1,n,1,n);
	dfs(rt,1); 
	bfs(rt);
	int sum=0;
	vector<int>::iterator ss;
	vector<int>::iterator ee;
	for(int i=1;i<=flor;i++)
	{
		if(i%2==1)
		{
			ss=res.begin();
			for(int j=0;j<sum;j++,ss++);
			ee=ss;			
			for(int j=0;j<flo[i];j++,ee++);
			reverse(ss,ee);
		}
		sum+=flo[i];
	}
	for(int i=0;i<n;i++)
	{
		cout<<res[i];
		if(i==n-1)cout<<endl;
		else cout<<" ";
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值