PAT-1127 ZigZagging on a Tree

1127 ZigZagging on a Tree(30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

    根据中序后序建树,然后层序输出。

#include<stdio.h>
#include<stdlib.h>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;

int in[35];
int post[35];
int n;
typedef struct node{//树节点
	int v;
	node *left,*right;
}node;
node* tree;
vector<int> level;//用于层序输出
node* newnode(int v){
	node *nd=(node*)malloc(sizeof(node));
	nd->v=v;
	nd->left=NULL;
	nd->right=NULL;
	return nd;
}
void build(int b1,int e1,int b2,int e2,node* root,bool isleft){//递归建树
	if(e1<b1) return ;
	int rootv=post[e2];
	node* nd=newnode(rootv);
	if(root==NULL)
		tree=nd;
	else{
		if(isleft)
			root->left=nd;
		else
			root->right=nd;
	}
	int inr=b1;
	for(;in[inr]!=rootv;inr++)
		;
	int lchnum=inr-b1;
	build(b1,inr-1,b2,b2+lchnum-1,nd,true);//left
	build(inr+1,e1,b2+lchnum,e2-1,nd,false);//right
}
void print(bool isLR){//正反序输出
	if(isLR){
		for(int i=0;i<level.size();i++){
			if(level[i]!=tree->v)printf(" ");
			printf("%d",level[i]);
		}
	}else{
		for(int i=level.size()-1;i>=0;i--){
			if(level[i]!=tree->v)printf(" ");
			printf("%d",level[i]);
		}
	}
}
int main(){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",in+i);
	}
	for(int i=0;i<n;i++){
		scanf("%d",post+i);
	}
	build(0,n-1,0,n-1,NULL,true);//建树
	queue<node> q;
	q.push(*tree);
	int tag=tree->v;bool pre,lr=true;
	while(!q.empty()){
		node t=q.front();
		q.pop();
		if(tag==t.v){
			pre=true;
			print(lr);//输出上一层
			lr=!lr;
			level.clear();
		}
		level.push_back(t.v);

		if(t.left!=NULL){
			if(pre){
				pre=false;
				tag=t.left->v;
			}
			q.push(*t.left);
		}
		if(t.right!=NULL){
			if(pre){
				pre=false;
				tag=t.right->v;
			}
			q.push(*t.right);
		}
	}
	print(lr);

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值