POJ - 1064 Cable master

Cable master
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 50230 Accepted: 10561
Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a “star” topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number “0.00” (without quotes).
Sample Input

4 11
8.02
7.43
4.57
5.39
Sample Output

2.00
Source

Northeastern Europe 2001

本题题意是问再n个不同长度下要求切出k个相同长度的线段 求这个最大长度
本题选择用二分
如何二分呢
由于要k个 而且n个绳子均为不同长度 所以要去枚举一个长度 拿到每一个绳子里去判断
能否凑够k个 如果可以 还没结束 需要继续向下枚举 因为我要最大长度
关键这样太慢
由于
大的范围没问题 那么小的范围一定没问题
判定成功 那么可以继续搜索
二分枚举就快多了

code:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

typedef long long ll;
const int maxn = 10010;
const int mn = 10000005;
int a[maxn],n,k;

bool check(int x){
    int c=0;
    for(int i=1;i<=n;i++)c+=a[i]/x;
    return c>=k;
}

int main()
{
    scanf("%d%d",&n,&k);
    for(int i=1;i<=n;i++){
        double f;
        scanf("%lf",&f);
        a[i] = (int)(f*100) ;//为了避免精度误差 可以将其化为整数做 
    }

    int l = 1,r = mn,ans=0;
    while(l<=r){
        int mid = (l+r)>>1;
        if(check(mid))ans = mid,l = mid+1;// 判定成功 可以继续搜索 向右靠拢
        else r = mid-1;
    }
    printf("%.2f\n",(double)ans/100.0);//这里很纠结 用%f输出AC 用%lf输出就WA
    return 0;
}

第二种写法 就是用for循环 能够搜到很小的精度

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

typedef long long ll;
const double M = 100005.0;
const int maxn = 10010;
double a[maxn];
int n,k;
bool check(double x){
    int c=0;
    for(int i=1;i<=n;i++)c+=(int)(a[i]/x);
    return c>=k;
}
int main()
{
    scanf("%d%d",&n,&k); 
    for(int i=1;i<=n;i++)scanf("%lf",&a[i]);

    double l = 0,r = M,ans=0;
    for(int i=1;i<=100;i++){    
        double mid = (l+r)/2;
        if(check(mid))ans = mid,l = mid;
        else r = mid;
    }
    printf("%.2lf\n",floor(ans*100)/100);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值