西安电子大学计算机考研复试机试(2019)+ 算法笔记 + 数学问题(PAT B1019/A1069 数字黑洞)

PAT B1019/A1069 数字黑洞

1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000
#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;

// 拆解+排序后重组+剪
int fun (int n){
	int a[4]={0},i=0,x1=0,x2=0;
	while(i<4){ // 不能用n%10!=0作为条件,因为可能数字内部含有0时也会跳出循环 
		a[i] = n%10;
		n/=10;
		i++;
	}
	
	sort(a,a+4);

	for(int j = 0;j<4;j++){
		x1 = a[3-j] + x1*10;
		x2 = a[j] + x2*10;
	}	
	printf("%04d - %04d = %04d\n",x1,x2,x1-x2); // 不足四位用0补齐 
	return x1-x2;	
} 
int main(){
	int n;
	while(cin>>n){
		int x = fun(n);  // cout<<"x:"<<x<<endl;
		while(x!=0&&x!=6174){
			x = fun(x);
		}
	}
	return 0;
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值