Description
给定两个字符串,输出两个字符串的最长公共子序列长度
Input
输入2个字符串(保证字符串长度不超过500)
文件有多组数据以‘#’号结束
Output
输出最长公共子序列长度
Sample Input
abc
abc
abcd
acdef
#
Sample Output
3
3
代码区:
#include <iostream>
#include <cmath>
#include <string.h>
using namespace std;
string a,b;
int lcs[505][505];
int main()//此题是求最大公共子序列,要和最大公共子串分清楚,前者可不连续,后者要连续
{
while(cin >> a)//可输入多组测试数据
{
memset(lcs,0,sizeof(lcs));//初始化
if(a=="#")//当输入为#时,退出循环
break;
cin >> b;
int n=a.size();//a的长度
int m=b.size();//b的长度
a=" "+a;//此处将字符串前面加上一个空格,方便后面进行-1不至于下标越界
b=" "+b;
for(int i=1;i<=n;++i)
for(int j=1;j<=m;++j)
if(a[i]==b[j])lcs[i][j]=lcs[i-1][j-1]+1;
//当a[i]与b[j]相等的时候,lcs等于不取这两个字母时的值+1
else lcs[i][j]=max(lcs[i-1][j],lcs[i][j-1]);
//当不相等的时候,值保持不变,因为我们是要找最大值,所以取各自退一格的值的最大值
cout << lcs[n][m] << endl;//推到最后一个时,为我们要求的最大子序列的个数
}
return 0;
}
列了个表格,当两个字母不相等的时候取上方和左方两者之间的最大值,
当两个字母相等的时候,取左上方的值+1
a | t | g | l | |
a | 1 | 1 | 1 | 1 |
g | 1 | 1 | 2 | 2 |
p | 1 | 1 | 2 | 2 |
l | 1 | 1 | 2 | 3 |
新手上路,有错请指正