(BFS/DFS)POJ 1979 Red and Black


Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 31376 Accepted: 17119

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13


思路:一道很正宗的BFS,不过DFS也可以,熟悉算法思想的不用多说,一看就明白。

//DFS

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define MAX_N 20
int W, H;
char a[MAX_N][MAX_N];
int res=0;
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};
int x,y;
void dfs(int nx, int ny)
{
    int i;
     if(nx >= 0 && nx < H && ny >= 0 && ny < W && a[nx][ny] =='.')
	 {
	     a[nx][ny] = '#';
		 res++;
	 }
	 else
		 return;

	 	for(i = 0; i < 4; i++)
		{
			x = nx + dx[i];
			y = ny + dy[i];
			if(a[x][y]=='.')
			{
				dfs(x,y);
			}
		}

}

int main()
{
	int nx=0 , ny=0;
	int i, j;

	while(scanf("%d%d\n",&W, &H) && (W || H))
	{
		for(i=0; i<H; i++)
		{
			for(j=0; j<W; j++)
			{
				scanf("%c",&a[i][j]);
				if(a[i][j]=='@')
				{
					nx = i;
					ny = j;
				}
			}
			getchar();
		}
		a[nx][ny] = '.';
		dfs(nx,ny);
	    printf("%d\n",res);
		res=0;
	}
	//system("PAUSE");
	return 0;
}



//BFS
#include <stdio.h>
#include <queue>
using std::queue;

#define MAXN 25
bool vis[MAXN][MAXN];
char map[MAXN][MAXN];
int W, H, result;
int dx[4] = {1, 0, -1, 0}, dy[4] = {0, -1, 0, 1};

struct Tile { // 以状态(棋子坐标)为结点
    int x, y;
}tile[MAXN*MAXN];

queue <Tile> q;

bool reachable(Tile next)
{
    return map[next.x][next.y] != '#' && next.x >= 1 && next.x <= W && next.y >= 1 && next.y <= H;
}

void bfs()
{
    Tile cur, next;
    while (!q.empty())
    {
        cur = q.front();
        q.pop();
        result++;
        for (int i = 0; i < 4; ++i)
       {
            next.x = cur.x + dx[i];
            next.y = cur.y + dy[i];
            if (reachable(next) && !vis[next.x][next.y])
            {
               vis[next.x][next.y] = true;
               q.push(next);
            }
        }
    }
}

int main()
{
    int i, j;
    Tile start;
    while (scanf("%d%d", &W, &H), W && H)
    {
        result = 0;
        memset(vis, false, sizeof(vis)); // 数据初始化
        for (i = 1; i <= H; ++i)
            for (j = 1; j <= W; ++j)
            {
                scanf(" %c", &map[i][j]); // x y
                if (map[i][j] == '@')
                {
                    start.x = j;
                    start.y = i;
                    vis[j][i] = true;
                    q.push(start);
                }
            }
        bfs();
        printf("%d\n", result);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值