hdu 1009 FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 77049    Accepted Submission(s): 26462


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
  
  
13.333 31.500
解题思想:贪心算法 先求单价,然后排个序就行了。
java代码


import java.util.Scanner;

public class hud1009 {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner scan=new Scanner(System.in);
		int m,n;
		double sum;
		while(((m=scan.nextInt())!=-1)&&((n=scan.nextInt())!=-1)){
			sum=0;
			double j[]=new double[n];
			double f[]=new double[n];
			double p[]=new double[n];
			for(int i=0;i<n;i++){
				double a=scan.nextDouble();
				double b=scan.nextDouble();
				j[i]=a;
				f[i]=b;
				p[i]=a/b;
			}
			sort(j,f,p,n);
			
			for(int i=0;i<n;i++){
				if(m>=f[i]){
					sum+=j[i];
					m-=f[i];
				}else{
					sum+=p[i]*m;
					break;
				}
			}
			System.out.printf("%.3f",sum);
			System.out.println();
		}
	}

	private static void sort(double[] j, double[] f, double[] p, int n) {
		// TODO Auto-generated method stub
		double temp;
		double temp1;
		double temp2;
		for(int i=0;i<n-1;i++){
			for(int k=0;k<n-1-i;k++){
				if(p[k]<p[k+1]){
					temp=p[k];
					p[k]=p[k+1];
					p[k+1]=temp;
					
					temp1=f[k];
					f[k]=f[k+1];
					f[k+1]=temp1;
					
					temp2=j[k];
					j[k]=j[k+1];
					j[k+1]=temp2;
				}
			}
		}
	}

}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值