POJ 2376 Cleaning Shifts 贪心

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21929 Accepted: 5472
Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
    Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
    Sample Input

3 10
1 7
3 6
6 10
Sample Output

2
使用贪心法。首先将区间按开始时间从小到大排序,开始时间相等按结束时间从小到大排序。

1 如果第一个区间不是从1开始,则无法覆盖,输出-1。

2 令当前覆盖到的时间time为开始时间为1的区间中结束时间的最大值。

3 从开始时间不为1的区间开始循环遍历。

4 选择合法区间中结束时间值最大的那个区间,合并到[1,time],合并后time为选择的区间的结束时间。所谓合法区间是指区间的起始时间start<=time+1,这样才能和区间[1,time]合并。如果没有找到合法区间或者找到的区间结束时间比time小,则无法覆盖,结束循环。

5 循环结束后,根据time是否大于等于T,输出结果。

AC代码

package 六月第四周;

import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

public class Main {

    /**
     * @param args
     */
    class Node{
        int x,y;
    }
    class cmp implements Comparator<Node>{

        @Override
        public int compare(Node o1, Node o2) {
            // TODO Auto-generated method stub
            if(o1.x>o2.x){
                return 1;
            }else if(o1.x<o2.x){
                return -1;
            }else{
                if(o1.y>o2.y){
                    return 1;
                }else if(o1.y<o2.y){
                    return -1;
                }else
                {
                    return 0;
                }

            }
        }

    }
    static Main poj=new Main();
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner scan=new Scanner(System.in);
        int t,n;
        n=scan.nextInt();
        t=scan.nextInt();
        Node node[]=new Node[n+2];
        for(int i=0;i<n;i++){
            node[i]=poj.new Node();
            node[i].x=scan.nextInt();
            node[i].y=scan.nextInt();
        }
        int i,ans,time,max_end,j;
        Arrays.sort(node,0,n,poj.new cmp());//排序 
        if(node[0].x!=1){//如果不是从1开始的就无法覆盖
            System.out.println("-1");
            return ;
        }
        else{
            time=node[0].y;
            i=1;
            while(node[i].x==1){//找到从1开始的区间最大结束区间
                time=node[i].y;
                i++;
            }
        }
        ans=1;  
        while(time<t){
            if(i>=n){
                break;
            }
            j=i;
            max_end=node[j].y;
            i++;
            while(i<n&&node[i].x<=time+1){//查找下一个区间开始时间小于等于上一个区域结束的时间
                if(node[i].y>max_end){
                    j=i;
                    max_end=node[i].y;
                }
                i++;
            }
            if(max_end<=time||node[j].x>time+1){
                break;
            }
            else{
                ans++;
                time=node[j].y;
            }
        }
        if(time<t){
            System.out.println("-1");
        }else{
            System.out.println(ans);
        }
    }

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值