poj3009 (dfs ,bfs)

8 篇文章 0 订阅
3 篇文章 0 订阅


Curling 2.0
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21420 Accepted: 8732

Description

On Planet MM-21, after their Olympic games this year, curling is getting

popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10

-1

AC代码 c++

#include<stdio.h>
#include<limits.h>
#define MAX 21
int map[MAX][MAX] ;
int h, w , min = INT_MAX ;//第一个要注意的就是坐标了,不能习惯性地去认为。
int sx , sy , ex, ey ;    //记录开始坐标和结束坐标
int d[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
void init(){//用于数据初始化的函数
 for(int i = 0 ;i < h ; i++)
  for(int j = 0 ; j < w ; j++)
  {
   scanf("%d",&map[i][j]) ;
   if(map[i][j] == 2)
   {
    map[i][j] = 0 ;//!!在程序将要完成的时候这里出现了问题,因为后面的程序没有
                   //处理2的情况所以干脆置为0好了
    sx = i ;
    sy = j ;
   }
   
    if(map[i][j] == 3)
    {
     ex = i ;
     ey = j ;
    }
  }
     min = INT_MAX ;//!因为有多组数据所以每一次都要刷新min的初始值INT_MAX
}
 
int ok(int x , int y){//判断是否越界的函数
if(x >=0 && x < h && y >=0 && y < w)
return 1 ;
return 0 ;
 }

void dfs(int step , int x , int y){//搜索
 
 if(step >=10)//如果超过10步,果断离开
 return ;
 for(int i = 0 ; i < 4; i++)//往四个方向探索
 {
    int k =x+d[i][0] , v = y+d[i][1] ;
  
    if(map[k][v] == 1)//如果在眼前有障碍物在走不通
    continue ;
  
    while(!map[k][v])//可行的路一直走到不是0的地方为止
    {
     k += d[i][0] ;
     v += d[i][1] ;
     printf("%d %d\n",k,v) ;
    }
    if(ok(k,v))//如果没有跑出界外
   {
     if(map[k][v] == 1){//如果此时在障碍物上面
     map[k][v] = 0 ;//击碎障碍物
     dfs(step+1 , k-d[i][0] , v-d[i][1]) ;//后退一步继续搜索!‘-’重要!
     map[k][v] = 1 ;//回溯要复原原来的场景
    }
   
      if(map[k][v] == 3){//如果刚好走到了目的地
       if(step+1 < min)//如果此时得到的步数要比已经得到的小则修改min的值
       min = step + 1;//因为step是从0开始计数的所以要加上1
    }
   }
 }
}
int main(){
 
 while(scanf("%d %d",&w,&h),h&&w)
 {
  init() ;
  dfs(0,sx,sy) ;
  if(min < INT_MAX)
  printf("%d\n",min) ;
  else
  printf("-1\n") ;
 } 
 return 0 ;
}


java 代码

import java.util.*;

class Node{     //只是将矩阵的坐标x,y保存到Node类中,也可以去掉,直接对x,y操作
	int x,y;
	Node(int x,int y){
		this.x=x;
		this.y=y;
	}
}

public class POJ3009_DFS {
	
	static final int[][] dis={{-1,0,},{1,0,},{0,-1,},{0,1,}};
	static final Scanner scan=new Scanner(System.in);
	static int a[][]=new int[25][25];
	static int w,h,ans,sx,sy;
	
	public static boolean isInRange(Node a){       //判断是否越界
		return a.x>=0&&a.x<h&&a.y>=0&&a.y<w;
	}
	public static void dfs(Node s,int step){
		if(step>10)return;
		if(ans==step)return;
    /*  Stack<Node> st=new Stack<Node>();//	st.push(s);     
		while(!st.empty()){ 
			Node h=st.pop();  */
			for(int i=0;i<4;i++){
				int judge=0;

                Node u=s;
				while(isInRange(u)){
					if(a[u.x][u.y]==1){
						break;    //跳出此次while循环
					}
					if(a[u.x][u.y]==3){
						if(ans>step)ans=step;
						return;                
					}
					judge++;
    				int nx=u.x+dis[i][0];
    				int ny=u.y+dis[i][1];
     				u=new Node(nx,ny);	
					
				}
				if(isInRange(u)&&judge>1){    //judge>1保证起点与墙壁之间有间隔,不是紧邻
	//				Node e=new Node(u.x-dis[i][0],u.y-dis[i][1]);
					a[u.x][u.y]=0;
					dfs(new Node(u.x-dis[i][0],u.y-dis[i][1]), step+1);
					a[u.x][u.y]=1;     //注意赋回来,不影响其他情况
	//				st.push(e);
				}
			}
//		}
	}

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		while(true){
			w=scan.nextInt();
			h=scan.nextInt();
			if(w==0&&h==0)break;                            //格式设置
			for(int i=0;i<h;i++){
				for(int j=0;j<w;j++){
					a[i][j]=scan.nextInt();
					if(a[i][j]==2){
						sx=i;
						sy=j;
						a[i][j]=0;
					}
				}
			}
			ans=11;
			dfs(new Node(sx,sy) ,1);
			if(ans>10)System.out.println("-1");
			else System.out.println(ans);
		}

	}

}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值