HUD2612 双路bfs

Find a way
Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23878    Accepted Submission(s): 7791

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki. 
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes. 

Input

The input contains multiple test cases. 
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character. 
‘Y’ express yifenfei initial position. 
‘M’    express Merceki initial position. 
‘#’ forbid road; 
‘.’ Road. 
‘@’ KCF 

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66

  此题的题意是Y和M要在KFC约会,给出一张图,图上可能有很多KFC,要求找到两人去KFC的时间的和的最小值。

第一次写双路bfs 写的有些复杂

#include<bits/stdc++.h>
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 205;
int vis[maxn][maxn];
int dis_y[maxn][maxn];
int dis_m[maxn][maxn];
int move_x[6] = {0, -1, 0, 1};
int move_y[6] = {1, 0, -1, 0};
string mp[maxn];
int y_x, m_x, y_y, m_y, minn;
int n, m;
struct node{
	int x;
	int y;
	int step;
	node() {}
	node(int a, int b, int c) : x(a), y(b), step(c) {}
};
queue<node> q;
void init(){
	memset(vis, 0, sizeof(vis));
	memset(dis_y, 0, sizeof(dis_y));
	memset(dis_m, 0, sizeof(dis_m));
	minn = inf;
	while(!q.empty()) q.pop();
}
void bfs(node w, int dis[][maxn]){
	node y = w;
	q.push(y);
	while(!q.empty()){
		y = q.front();
		q.pop();//
		for(int i = 0; i < 4; i++){
			int X = y.x + move_x[i];
			int Y = y.y + move_y[i];
			int t = y.step + 1;
			if(X < 0 || Y < 0 || X >= n || Y >= m || mp[X][Y] == '#' || vis[X][Y] == 1) continue;
			vis[X][Y] = 1;
			if(mp[X][Y] == '@') dis[X][Y] = t;
			q.push(node(X, Y, t));
		}
	}
}
int main(){
	while(cin >> n >> m){
		init();
		for(int j = 0; j < n; j++)
			cin >> mp[j];

		for(int i = 0; i < n; i++){
			for(int j = 0; j < m; j++){
				if(mp[i][j] == 'Y') 
					y_x = i, y_y = j;
				if(mp[i][j] == 'M')
					m_x = i, m_y = j;
			}
		}
		vis[y_x][y_y] = 1;
		bfs(node(y_x, y_y, 0), dis_y);
		memset(vis, 0, sizeof(vis));
		vis[m_x][m_y] = 1;
		bfs(node(m_x, m_y, 0), dis_m);
		for(int i = 0; i < n; i++){
			for(int j = 0; j < m; j++){
				if(dis_y[i][j] && dis_m[i][j])//注意判断条件如果是mp[i][j] == '@'的话可能出现走不到kfc的条件 就会wa minn = min(minn, dis_y[i][j] + dis_m[i][j]);
			}
		}
		cout << minn * 11 << endl;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值