动态规划之求最长上升子序列

Super Jumping! Jumping! Jumping!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58591 Accepted Submission(s): 27219

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output
4
10
3

这是一道经典的求最长上升子序列 什么是最长上升子序列呢?就是给你一串无序的数字 让你在这个序列当中去寻找有一定顺序的数字的长度(可以是升序也可以一是降序)这道题就是求升序 并且是总和

LICS:

    for(int i = 0; i < nums.length; i++) 
    {
        p[i] = nums[i];
    }
    int n = nums.length;
    p[n] = 1000000;
    n++;
    for(int idx = 0; idx < n; idx++)
     {
        int ans = 0;
        for(int i = 0; i < idx; i++) 
        {
            if (p[idx] > p[i])
             {
                ans = max(ans, f[i]);
             }
        }
        f[idx] = ans + 1;
    }
    return f[n - 1] - 1;
}

我们可以推一下公式 首先一个升序序列必须满足第i个数大于第i-1个数(废话)我们从给出的无序序列怎样进行筛选 首先是添加升序数进来 这个非常简单 只要满足a[i]>a[i-1]即可 可如果不满足这个条件 我们就需要从无序数里面筛选满足这个条件的数字 就可以推出 DP[i]=max(dp[i]+a[i],dp[i])

#include<bits/stdc++.h>
#include<string.h>
using namespace std;

const int mmax=50050;
int a[mmax],dp[mmax];
int main()
{
    int n,i,j;
    while(scanf("%d",&n)!=EOF)
    {
    	if(n==0)
    	  break;
        int ans=-99999;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            dp[i]=0;
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<i;j++)
            {
                if(a[i]>a[j])//在i位置往前寻找升序数 找到升序数就加上
                {
                    dp[i]=max(dp[j]+a[i],dp[i]);
                }
            }
            dp[i]=max(a[i],dp[i]);
        }
        for(i=1;i<=n;i++)
           ans=max(ans,dp[i]);
        printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值