动态规划之多重背包

多重背包 W-w[i]

Dividing
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34827 Accepted Submission(s): 9775

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0’’. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0’’; do not process this line.

Output
For each colletcion, output Collection #k:'', where k is the number of the test case, and then eitherCan be divided.’’ or ``Can’t be divided.’’.

Output a blank line after each test case.

Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output
Collection #1:
Can’t be divided.

Collection #2:
Can be divided.

多重背包我们需要运用到二进制的优化 把这件物品放进背包的最大容量拆分成几个同样价值的物品 因为任何一个正整数我们都可以采用二进制进行表示 比如8=1+1+2+4(1000)=2^3 通过二进制的拆分 我们把背包全装该物品最大件数的8拆分成一件的价值重量 两件的价值重量 四件的价值重量 一件的价值重量 分别用这一件,两件,四件,一件去填背包 这就转成了0-1背包的问题了 我们只需要分别对这一件,两件,四件,一件进行编号就行了 再跑一边零一背包

先给出二进制优化的代码吧

for(int i=1;i<=n;i++)
{
       for(int j=1;j<=mamx[i](W/w[i]最多件数);j<<=1)
       {
               weight[++tot]=j*w[i];
               value[tot]=j*v[i];
               mamx[i]=mamx[i]-j;
       }
       if(mamx[i]>0)//对最后一个进行处理
       {
               weight[++tot]=mamx[i]*w[i];
               vlaue[tot]=mamx[i]*v[i];
       }
}
#include<bits/stdc++.h>
using namespace std;

const int mmax=50000;
int f[mmax],k[mmax],v[7]= {0,1,2,3,4,5,6},a[mmax];
int main()
{
	int i,j,op;
    for(op=1;;op++)
    {
        memset(f,0,sizeof(f));
        int sum=0;
        for(i=1; i<=6; i++)
        {
            scanf("%d",&k[i]);
            sum+=k[i]*i;
            v[i]=i;
        }
        if(sum==0)
          break;
        int hh=sum;
        if(sum%2==1)
            printf("Collection #%d:\nCan't be divided.\n\n",op);
        int index=0;
        if(sum%2==0&&hh!=0)
        {
            for(i=1; i<=6; i++)
            {
                for(j=1;j<=k[i];j*=2)
                {
                    a[++index]=j*v[i];
                    k[i]-=j;
                }
                if(k[i]>0)
                  a[++index]=v[i]*k[i];
            }
            sum/=2;
            for(i=1; i<=index; ++i)
            {
                for(j=sum; j>=a[i]; --j)
                    f[j]=max(f[j],f[j-a[i]]+a[i]);
            }
            if((hh-f[sum])!=sum)
                printf("Collection #%d:\nCan't be divided.\n\n",op);
            if((hh-f[sum])==sum)
                printf("Collection #%d:\nCan be divided.\n\n",op);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值