ALDS1_3_B:Queue

输入:数量n 单个任务最长执行时间

输出:n行 每行任务名称+任务所需时间

如果任务需要时间超出了最长执行时间,则将所需时间减去最长执行时间后再压入队列尾部。直到栈为空结束。

 

 

Sample Input 1

5 100
p1 150
p2 80
p3 200
p4 350
p5 20

Sample Output 1

p2 180
p5 400
p1 450
p3 550
p4 800

 

#include <cstdio>
#include <queue>
#include <string>
#include <vector>
#include <algorithm>
#include <iostream>
using namespace std;
int main(){
	int n , p ,t ;
	string name;
	int timeflow=0;
	cin>>n>>p;
	queue<pair<string,int> > A;
	for(int i = 1 ; i<=n;i++){
		cin>>name>>t;
		A.push(make_pair(name, t));
	}
	while(!A.empty()){
		if(A.front().second<=p){
			timeflow+=A.front().second;
			cout<<A.front().first<<" "<<timeflow<<endl;
			A.pop();
		}
		else{
			timeflow+=p;
			A.front().second-=p;
			A.push(A.front());
			A.pop();
		}
	}
	return 0;
}

 

错点:

1.定义时 要写成queue<pair<string,int> > 最后的尖括号之间要有空格

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值