【NEEPU OJ】1011--Power Function

描述

Given x , print the left-most decimal digit of f(x) with sign.
if x is a odd number then f(x) = (-1) * ( 2 ^ x ) ,
Otherwise f(x) = 2 ^ x .
note : 2 ^ x means, xth power of 2.

输入

Input starts with an integer T (1<=1000), denoting the number of test cases. Each case contains an integer x (1 ≤ x ≤ 60) .

输出

For each case of input, output the left-most decimal digit of f(x).

输入样例 1

3
1
2
10

输出样例 1

-2
+4
+1

来源

Dev skill


代码(类型转换)
#include <iostream>
#include <cmath>
#include <string>
#include <sstream>
using namespace std;

int main(){
    int t;
    long long x;
    string res;
    stringstream sstr;
    cin >> t;
    while(t--){
        cin >> x;
        if(x % 2 == 1) x = -pow(2, x);
        else x = pow(2, x);
        sstr << x;
        sstr >> res;
        if(x > 0){
            cout << "+" + res.substr(0, 1) << endl;
            sstr.clear();
        }
        else{
            cout << res.substr(0, 2) << endl;
            sstr.clear();
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值