2016SDAU课程练习一1015



Problem P 

Problem Description
The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 


Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 


Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.
 


Input
* Line 1: Two space-separated integers, N and S. <br> <br>* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.
 


Output
* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.
 


Sample Input
4 5
88 200
89 400
97 300
91 500 


Sample Output

126900 


题意:输入每天需求酸奶数目和生产价格,可以用当天的也可以用前一天的,但是保存一天有每单位保存费,求最少花费


思路:比较当天和前一天的价格取小就行了,再加上保存费


感想:做了几道题其实实质都差不多啊


AC代码:

#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
int a[10005];
int y[10005];
int main()
{
    //freopen("r.txt", "r", stdin);
    long long sum=0;
    int day,s,i;
    cin>>day>>s;
    for(i=1;i<=day;i++)
    {
        cin>>a[i];
        cin>>y[i];
        if(i==1)
        {
            sum+=a[i]*y[i];
            continue;
        }
        if(a[i-1]+s<a[i])
            sum+=(a[i-1]+s)*y[i];
        else
        {
            sum+=a[i]*y[i];
        }
    }
    cout<<sum<<endl;


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值