2016SDAU编程练习二1013


A strange lift 


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 &lt;= Ki &lt;= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button &quot;UP&quot; , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button &quot;DOWN&quot; , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button &quot;UP&quot;, and you'll go up to the 4 th floor,and if you press the button &quot;DOWN&quot;, the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button &quot;UP&quot; or &quot;DOWN&quot;?<br>
 


Input
The input consists of several test cases.,Each test case contains two lines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.<br>A single 0 indicate the end of the input.
 


Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 


Sample Input
5 1 5<br>3 3 1 2 5<br>0 


Sample Output

3


题意:有一个特别的电梯,第i层有一个对应的数字ki, 对于第i层按上升键up可升上到i+k[i]层,按下降键down到达i-k[i]层,到达的楼层最高不能超过n层,最低不能小于1层。给你一个起点A和终点B,问最少要按几次上升键或者下降键到达目的地。

思路:乍一看有点像贪心,BFS

感想:搜索好。。。。长。。。。。

AC代码:

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
struct node
{
   int x ;
   int y ;
}n1,n2,m;
int c[2000],d[2000];  //标记数组,和一个记录楼层状态的数组
int flag ;                 //记录能否到达目标楼层
int n , a , b ;          //n层,a,起始楼层,b,目的楼层
int main(  )
{
    while( scanf("%d" , &n ) , n )
    {
       if( n== 0 ) break ;        //结束
       cin>>a>>b;
       for( int i= 1;  i<= n ; i++ )     //初始化
       { cin>>d[i] ; c[i] = 0 ; }
       flag = 0 ;                      //初始为0
       n1.x = a ; n1.y = 0 ;        //把a开始所在楼层赋给结构体, 所走步数为0
       queue<node>Q;               //建立队列Q
       Q.push(n1);                        //入队
       c[n1.x] = 1 ;          //标记已经走过
       while( !Q.empty() )       //直到为空为止
       {
          m = Q.front() ;            //把队列中第一个值赋给结构体变量m
          Q.pop();                   //出队
          if( m.x == b )            //如果到达终点便退出
          { flag = 1 ; break ; }
          n1.x = m.x - d[m.x];  //按向下的按钮
          n2.x = m.x + d[m.x]; //按向上的按钮
          if( n1.x>0 && n1.x<= n&& !c[n1.x] )//向下
          {
                n1.y = m.y + 1 ;         //步数加一
                c[n1.x] = 1 ;       //标记
                Q.push(n1);
              }
            if( n2.x>0 && n2.x<= n && !c[n2.x] )//向上
             {
                n2.y = m.y+1 ;
                c[n2.x] = 1 ;
                Q.push(n2);
             }
       }
       if( flag ) cout<<m.y<<endl;
       else cout<<"-1"<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值