hdu 1247 Hat’s Words (字典树)


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1247


Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13401    Accepted Submission(s): 4790


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
  
  
a ahat hat hatword hziee word
 

Sample Output
  
  
ahat hatword
 

Author
戴帽子的
 

Recommend
Ignatius.L
 

Statistic |  Submit |  Discuss |  Note

题目大意: 给你几个字符串,求其中一些特殊字符串,就是该字符串由其他两个字符串构成,


解析: 字典树

代码如下:

#include<iostream>
#include<algorithm>
#include<map>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 33
using namespace std;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 + 7;
char s[50009][N];
typedef struct node
{
    int cnt;
    struct node *n[N];
    node()
    {
        cnt = 1;
        memset(n, 0, sizeof(n));
    }
}Q, *T;
T root = new node();

void Creat(char s[])
{
    T q = root;
    for(int i = 0; s[i]; i++)
    {
        int id = s[i] - 'a';
        if(q->n[id] == NULL)
            q->n[id] = new node();
        q = q->n[id];
    }
    q->cnt = -1;
}

int Find(char s[])
{
    T q = root;
    for(int i = 0; s[i]; i++)
    {
        int id = s[i] - 'a';
        if(q->n[id] == NULL)
            return 0;
        q = q->n[id];
    }
    if(q->cnt == -1)
       return 1;
    return 0;
}

void F(T S)
{
    if(S == NULL) return ;
    for(int i = 0; i <= 26; i++)
    {
        if(S->n[i]) F(S->n[i]);
    }
    delete S;
    S = NULL;
}

int main()
{
    int j = 0;
    while(gets(s[j]), s[j][0] != '\0')
    {
        Creat(s[j]);
        j++;
    }
    char a[N], b[N];
    for(int i = 0; i < j; i++)
    {
        int len = strlen(s[i]);
        for(int j = 1; j < len; j++)
        {
            memset(a, 0, sizeof(a));
            memset(b, 0, sizeof(b));
            strncpy(a, s[i], j);
            strncpy(b, s[i]+j, len-j);
            //cout << a << "   " << b << endl;
            if(Find(a) && Find(b))
            {
                printf("%s\n", s[i]);
                break;
            }
        }
    }
    F(root);
    return 0;
}



评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值