Poj 1836 Alignment (双重LIS)

题目链接:http://poj.org/problem?id=1836


Alignment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16124 Accepted: 5265

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source


题目大意:给出一个队列的身高,要求队列中的每个人从左往右看(或者从右往左)都能看到前面的人头,求从中踢出的最少人数

解析:双重LIS


代码如下:

#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<cctype>
#include<cmath>
#define N 40009
using namespace std;
const double inf = 0x3f3f3f3f * 1.0;
const int mod = 1e9 + 7;
const double eps = 1e-8;
const double pi = acos(-1.0);
typedef long long LL;
double a[N];
int dp1[N], dp2[N];

int main()
{
    int i, j, n;
    while(~scanf("%d", &n))
    {
        if(n == 0) {printf("0\n"); continue;}

        for(i = 1; i <= n; i++)
           scanf("%lf", &a[i]);

        for(i = 1; i <= n; i++)
        {
            dp1[i] = 1;
            for(j = 1; j < i; j++)
            if(a[i] > a[j])
                dp1[i] = max(dp1[j] + 1, dp1[i]);
        }

        for(i = n; i >= 1; i--)
        {
            dp2[i] = 1;
            for(j = n; j > i; j--)
            if(a[i] > a[j])
                dp2[i] = max(dp2[j] + 1, dp2[i]);
        }
        int ans = 0;
        for(i = 1; i <= n; i++)
        for(j = i + 1; j <= n; j++)
            ans = max(ans, dp1[i] + dp2[j]);

        printf("%d\n", n - ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值