poj 3349 Snowflake Snow Snowflakes(hash)

题目链接:http://poj.org/problem?id=3349

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 40754 Accepted: 10734

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top



题意:给你两朵雪花,问这两朵雪花通过旋转,是否一样

解析:hash一下,这朵雪花的六个瓣的和,就是 mod 100007,然雪花旋转比较下就可以了


代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#define N 100009
using namespace std;
const int INF = 0x3f3f3f3f;
const int mod = 1e5 + 7;

vector<int> h[N];
int snow[N][7], sum[N];

bool check(int a, int b)
{
    for(int i = 0; i < 6; i++)
    {
        if(snow[a][0] == snow[b][i%6])
        {
            if(snow[a][1] == snow[b][(i+1)%6] && snow[a][2] == snow[b][(i+2)%6] && snow[a][3] == snow[b][(i+3)%6] && snow[a][4] == snow[b][(i+4)%6] && snow[a][5] == snow[b][(i+5)%6])
                return true;
        }
        if(snow[a][5] == snow[b][i%6])
        {
            if(snow[a][4] == snow[b][(i+1)%6] && snow[a][3] == snow[b][(i+2)%6] && snow[a][2] == snow[b][(i+3)%6] && snow[a][1] == snow[b][(i+4)%6] && snow[a][0] == snow[b][(i+5)%6])
                return true;
        }
    }
    return false;
}


int main()
{
    int n, f = 0;
    scanf("%d", &n);
    memset(sum, 0, sizeof(sum));
    for(int i = 0; i < n; i++) h[i].clear();
    for(int i = 0; i < n; i++)
    {
        sum[i] = 0;
        for(int j = 0; j < 6; j++)
        {
            scanf("%d", &snow[i][j]);
            sum[i] += snow[i][j];
        }

    }
    for(int i = 0; i < n; i++)
    {
        int key = sum[i] % mod;
        for(int j = 0; j < h[key].size(); j++)
        {
            if(check(i, h[key][j])) f = 1;
            if(f) break;
        }
        if(f) break;
        h[key].push_back(i);
    }
    if(f) puts("Twin snowflakes found.");
    else puts("No two snowflakes are alike.");
    return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值