hdu 1097 A hard puzzle (快速幂)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1097


A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43225    Accepted Submission(s): 15662


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
  
  
7 66 8 800
 

Sample Output
  
  
9 6
 

Author
eddy
 

Recommend
JGShining
 

Statistic |  Submit |  Discuss |  Note


题意:求a^b的最后一位

解析:由于a, b比较大,需要用到快速幂


代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<map>
#include<cmath>
#define N 10009
using namespace std;
const int INF = 0x3f3f3f3f;
int q_mod(long long a, long long b)
{
    long long ans = 1ll;
    while(b)
    {
        if(b&1) ans = ans * a % 10;
        a = (a % 10) * (a % 10) % 10;
        b >>= 1;
    }
    return ans % 10;
}

int main()
{
    int a, b;
    while(~scanf("%d%d", &a, &b))
    {
        cout << q_mod(a, b) << endl;
    }
    return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值