hdu 6168 Numbers

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6168


Numbers

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 631    Accepted Submission(s): 335


Problem Description
zk has n numbers  a1,a2,...,an . For each (i,j) satisfying 1≤i<j≤n, zk generates a new number  (ai+aj) . These new numbers could make up a new sequence  b1b2,...,bn(n1)/2 .
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
 

Input
Multiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each  ai  is in [1,10^9]
 

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers  a1,a2,...,an(a1a2...an) . These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.
 

Sample Input
  
  
6 2 2 2 4 4 4 21 1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
 

Sample Output
  
  
3 2 2 2 6 1 2 3 4 5 6
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6170  6169  6168  6167  6166 
 

Statistic |  Submit |  Discuss |  Note

解析:求原来的数组,先排下序,最小的两个一定是原数组,然后一个一个的取,取完之后进行组合,把取出来的和求的和从数组中删除,一直重复这个操作即可

代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int N = 125250+100;

int a[N], b[N];
map<int, int> mp;

int main()
{
    int n, len;
    while(~scanf("%d", &n))
    {
        mp.clear();
        len = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d", &a[i]);
            mp[a[i]]++;
        }
        sort(a, a+n);
        b[len++] = a[0]; b[len++] = a[1];
        mp[a[0]]--; mp[a[1]]--;
        int cur = a[0] + a[1], j = 2;
        mp[cur]--;
        while(j < n)
        {
            while(j < n && !mp[a[j]]) j++;
            if(j >= n) break;
            int cur = a[j];
            mp[cur]--;
            for(int i = 0; i < len; i++)
            {
                int d = b[i] + cur;
                if(mp[d]) mp[d]--;
            }
            b[len++] = cur;
        }
        printf("%d\n", len);
        for(int i = 0; i < len; i++) printf("%d%c", b[i], i == len-1 ? '\n' : ' ');
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值