poj 1704 Georgia and Bob (尼姆博奕)

20 篇文章 1 订阅
Georgia and Bob
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9583 Accepted: 3144

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

Source

POJ Monthly--2004.07.18


题目大意:
        一个1*M的棋盘上有N个棋子,初始位置一定,两人轮流操作,
       每次移动一枚棋子,要求只能向左移且至少移动一格,而且不
        能到达或经过以前有棋子的格子,谁无法移动棋子就算输。
解题思路:

很巧妙的转化为Nim游戏,首先相邻的两个作为1组,如果是奇数,就第一个和0作为1组,然后如果移动每组的前一个棋子,其实是没有影响的,因为后手可以跟他一样,把后面的棋子移动一样的步数,而移动后手,相当于把一个区间缩短,这样一个区间的长度就等同于Nim游戏中石子的数量,转化为了Nim游戏

思考过程:最终状态必然所有的的球排满前m个小格,若将它恢复原来的样子,你必须先把最后两个间隔恢复,接着两个都要后移,你会发现在移动的过程中,一对球的相对位置没有改变,因为我们移动前一个球多少后面的也移动多少,因为球是成对的你移动一个的位置,对手可以移动一样的位置,问题是对手会不会移动那么多位置呢?答案是肯定的,因为最后都连到也一起去了,因为球是成对的你移动一个的位置,对手可以移动一样的位置,对称性,你移动的这个对最后结果肯定没影响,因为先手能移后手肯定能动,那么这样就将所有的小球两两绑定了,若只有奇数个就将第一个球和左边界绑定。成对后sg值很好求就是他们的间隔。由组合博弈可以得出结果。


#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 1e3 + 5;
int a[maxn];
int main()
{
    int t, n;
    scanf("%d" ,&t);
    while(t--)
    {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
        int ans = 0;
        sort(a+1, a+1+n);
        if(n % 2)
        {
            ans ^= (a[1]-1);   //因为两个不可以在一起,所以要-1
            for(int i = 3; i <= n; i+=2)
            {
                ans ^= (a[i] - a[i-1] - 1);
            }
        }
        else
        {
            for(int i = 2; i <= n; i+=2)
                ans ^= (a[i] - a[i-1] - 1);
        }
        if(ans == 0) printf("Bob will win\n");
        else printf("Georgia will win\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值