poj 3321 Apple Tree(dfs染色+树状数组)



Apple Tree
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 27212 Accepted: 8073

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

题意:
给出一个苹果树,每个节点一开始都有苹果
C X,如果X点有苹果,则拿掉,如果没有,则新长出一个
Q X,查询X点与它的所有后代分支一共有几个苹果

思路:

由于此题数据比较大(N<=10^5),而且不是标准的二叉树,所以这里我们队每一个节点重新编号,另外为每一个节点赋一个左值和一个右值,表示这个节点的管辖范围。


上图也就是DFS搜索的时候做标记的过程,这样新的编号为1~6的节点所管辖的范围分别就是[1,6] [2,4] [3,3] [4,4] [5,6] [6,6],其中左边的是左值,右边的是右值,节点1的区间是[1,6],正好这棵子树有6个节点,其他也一样
那我们吧新的节点放进树状数组时


那我们求出每一个节点从1~左值的和 和 1~右值的和 他们的差就是这个节点的子树的所有的和(即这棵子树苹果数目)

其实就是从这个点开始往下递归,每次都给当前这个点+1,递归到不能递归就是这个点能到达的最远的地方。。。

<span style="font-size:24px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 1e5 + 5;
int k, head[maxn], l[maxn], r[maxn], c[maxn], n, tot, m, apple[maxn]; //l数组代表这个点最近的点,r数组代表他子节点最远的点
struct node  //链式前向星存,这题卡vector
{
    int v, next;
}edge[maxn];
void addedge(int u, int v)
{
    edge[k].v = v;
    edge[k].next = head[u];
    head[u] = k++;
}
void dfs(int pos)   //这里是这一题的精髓,用dfs进行给每个值编号
{
    l[pos] = tot; //这个点的开始肯定是没进入递归的tot
    for(int i = head[pos]; i != -1; i = edge[i].next)
    {
        tot++;
        dfs(edge[i].v);  //每个点往下走
    }
    r[pos] = tot;  //递归到不能递归,就说明最后那个点是到达最远的地方
}
int lowbit(int k)
{
    return k & -k;
}
void update(int pos, int val)
{
    while(pos < maxn)
    {
        c[pos] += val;
        pos += lowbit(pos);
    }
}
int sum(int pos)
{
    int sum = 0;
    while(pos > 0)
    {
        sum += c[pos];
        pos -= lowbit(pos);
    }
    return sum;
}
int main()
{
    while(~scanf("%d", &n))
    {
        memset(c, 0, sizeof(c));
        memset(head, -1, sizeof(head));
        memset(l, 0, sizeof(l));
        memset(r, 0, sizeof(r));
        tot = 1;
        k = 1;
        int a, b;
        for(int i = 1; i < n; i++)
        {
            scanf("%d%d", &a, &b);
            addedge(a, b);
        }
        dfs(1);
        for(int i = 1; i <= n; i++)
            apple[i] = 1, update(i, 1);  //每个点开始有一个苹果。
        char cmd;
        scanf("%d", &m);
        while(m--)
        {
            scanf(" %c%d", &cmd, &a);
            if(cmd == 'C')
            {
                if(apple[a])
                    update(l[a], -1), apple[a] = 0; // 更新之后一定要对原数组更新
                else
                    update(l[a], 1), apple[a] = 1; //注意,这里的update更新的是l[a],是这个点的“编号”
            }
            else
            {
                printf("%d\n", sum(r[a]) - sum(l[a]-1));
            }
        }
    }
    return 0;
}
</span>


  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值