HDU 2767 Proving Equivalences (Tarjan缩点)【java】

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8650    Accepted Submission(s): 3076


Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0. 

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
 

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
 

Sample Input
 
 
2 4 0 3 2 1 2 1 3
 

Sample Output
 
 
4 2
 

Source
 

Recommend
lcy
 
题意: 
给定一张有向图,问最少添加几条边使得有向图成为一个强连通图。


分析: 
Tarjan入门经典题,用tarjan缩点,然后就变成一个有向无环图(DAG)了。 
我们要考虑的问题是让它变成强连通,让DAG变成强连通就是把尾和头连起来,也就是入度和出度为0的点。 
统计DAG入度和出度,然后计算头尾,最大的那个就是所求。
import java.util.Arrays;
import java.util.Scanner;
import java.util.Stack;
import java.util.Vector;

public class Main {
	static final int maxn = 30000;
	static final int maxm = 60000;
	static int[] dfn = new int[maxn];
	static int[] low = new int[maxn];
	static int[] id = new int[maxn];
	static int[] in = new int[maxn];
	static int[] out = new int[maxn];
	static int scc_cnt;
	static int dfn_cnt;
	static int _, n, m, x, y;
	static Vector<Integer>[] vt = new Vector[maxn];
	static Stack<Integer> s = new Stack(); 
	static void init() {
		Arrays.fill(dfn, 0);
		Arrays.fill(low, 0);
		Arrays.fill(id, 0);
		Arrays.fill(in, 0);
		Arrays.fill(out, 0);
		for(int i = 0; i < maxn; i++)
			vt[i].clear();
		s.clear();
		scc_cnt = 0;
		dfn_cnt = 0;
	}
	static void Tarjan(int u) {
		dfn[u] = low[u] = ++dfn_cnt;
		s.push(u);
		for(int i = 0; i < vt[u].size(); i++) {
			int v = vt[u].get(i);
			if(dfn[v] == 0) {
				Tarjan(v);
				low[u] = min(low[u], low[v]);
			}
			else if(id[v] == 0)
				low[u] = min(low[u], dfn[v]);
		}
		if(dfn[u] == low[u])
		{
			scc_cnt++;
			while(true) {
				int x = s.peek();
				s.pop();
				id[x] = scc_cnt;
				if(x == u) break;
			}
		}
	}
	static void scc()
	{
		for(int i = 1; i <= n; i++)
			if(dfn[i] == 0)
				Tarjan(i);
	}
	static private int min(int i, int j) {
		// TODO Auto-generated method stub
		if(i <= j) return i;
		else return j;
	}
	static private int max(int i, int j) {
		if(i >= j) return i;
		else return j;
	}
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		_ = sc.nextInt();
		for(int i = 0; i < maxn; i++)
			vt[i] = new Vector<Integer>();
		while(_-- > 0) {
			init();
			n = sc.nextInt();
			m = sc.nextInt();
			for(int i = 1; i <= m; i++) {
				x = sc.nextInt();
				y = sc.nextInt();
				vt[x].add(y);			
			}
			scc();
			if(scc_cnt == 1)
			{
				System.out.println(0);
				continue;
			}
			for(int i = 1; i <= n; i++)
			{
				for(int j = 0; j < vt[i].size(); j++)
				{
					int to = vt[i].get(j);
					if(id[i] != id[to])
					{
						out[id[i]]++;
						in[id[to]]++;
					}
				}
			}
			int out_cnt = 0, in_cnt = 0, ans = 0;
			for(int i = 1; i <= scc_cnt; i++) {
				if(out[i] == 0) out_cnt++;
				if(in[i] == 0) in_cnt++;
			}
			ans = max(out_cnt, in_cnt);
			System.out.println(ans);
		
		}
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值