题目描述
编写一个日期类,要求按xxxx-xx-xx 的格式输出日期,实现加一天的操作。
输入
输入第一行表示测试用例的个数m,接下来m行每行有3个用空格隔开的整数,分别表示年月日。测试数据不会有闰年。
输出
输出m行。按xxxx-xx-xx的格式输出,表示输入日期的后一天的日期。
样例输入
2 1999 10 20 2001 1 31
样例输出
1999-10-21 2001-02-01
提示
注意个位数日期前面要有0。
#include<stdio.h>
#include<string.h>
int month[13][2]={{0,0},{31,31},{28,29},{31,31},{30,30},{31,31},{30,30},{31,31},{31,31},{30,30},{31,31},{30,30},{31,31}};
#include<iostream>
using namespace std;
class Date{
public:
int yy;
int mm;
int dd;
//Date(){}
Date(int y,int m,int d)
{
yy=y;
mm=m;
dd=d;
}
};
int main()
{
int m;
scanf("%d",&m);
while(m--){
int year,mon,day;
scanf("%d%d%d",&year,&mon,&day);
//Date date1;
//Date date1;
Date date1(year,mon,day);
date1.dd++;
if(date1.dd>month[mon][0])
{
date1.dd=1;
date1.mm+=1;
}
if(date1.mm>12)
{
date1.yy+=1;
date1.mm=1;
}
printf("%04d-%02d-%02d\n",date1.yy,date1.mm,date1.dd);
}
return 0;
}