题目1440:Goldbach's Conjecture

题目1440:Goldbach's Conjecture

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:1974

解决:1214

题目描述:

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2. 
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

输入:

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

输出:

Each output line should contain an integer number. No other characters should appear in the output.

样例输入:
6
10
12
0
样例输出:
1
2

1

原题地址:http://ac.jobdu.com/problem.php?pid=1440

结题思路:

n=p1+p2.

  1. 利用素数筛选法先筛选出范围内的素数。n<=2^15
  2. 双层循环遍历范围内的素数是否满足条件,同时进行记录。

代码:

#include <iostream>
#define N 32768
using namespace std; 
/* run this program using the console pauser or add your own getch, system("pause") or input loop */


int prime[N];
int length=0;
bool mark[N];

void findPrime(){
	for(int i=0;i<N;i++){
		mark[i]=false;
	}
	
	for(int i=2;i<N;i++){
		if(mark[i] == true){
			continue;
		}
		
		mark[i]=true;
		prime[length++]=i;
		for(int j=i*i;j>0 && j<N;j+=i){
			mark[j]=true;
		}
	}
}
bool isPrime(int x){
	for(int i=0;i<length;i++){
		if(prime[i] == x){
			return true;
		}
	}
	return false;
}
int main(int argc, char *argv[]) {
	findPrime();
	 
	int n;
	cin>>n;
	while(n != 0){
		int ans=0;
		for(int i=0;i<length && prime[i]<n;i++){
			for(int j=0;j<length&& prime[j]<n;j++){
				//cout<<prime[i]<<" "<<prime[j]<<endl;
				if(n == prime[i]+prime[j]){
					ans++;
					if(i == j){
						//两个素数相等,即n/2为素数
						ans+=2; 
					}
				}		
			}
		}
		cout<<(ans)/2<<endl;  //因为n为偶数,当n/2为素数时, 
		
		cin>>n;
	}
	return 0;
}
代码分析:

for(int i=0;i<length && prime[i]<n;i++){
			for(int j=0;j<length&& prime[j]<n;j++){
双层循环后,(i,j)(i!=j)都计算了两次,因此对满足情况的(i,i)人为的加2,方便最后直接结果ans/2进行输出。

也可以考虑优化。

优化:对于(i,j)(i!=j)的情况可以只计算一次。优化后代码如下:

#include <iostream>
#define N 32768
using namespace std; 
/* run this program using the console pauser or add your own getch, system("pause") or input loop */


int prime[N];
int length=0;
bool mark[N];

void findPrime(){
	for(int i=0;i<N;i++){
		mark[i]=false;
	}
	
	for(int i=2;i<N;i++){
		if(mark[i] == true){
			continue;
		}
		
		mark[i]=true;
		prime[length++]=i;
		for(int j=i*i;j>0 && j<N;j+=i){
			mark[j]=true;
		}
	}
}
bool isPrime(int x){
	for(int i=0;i<length;i++){
		if(prime[i] == x){
			return true;
		}
	}
	return false;
}
int main(int argc, char *argv[]) {
	findPrime();
	 
	int n;
	cin>>n;
	while(n != 0){
		int ans=0;
		for(int i=0;i<length && prime[i]<n;i++){
			for(int j=i;j<length&& prime[j]<n;j++){
				//cout<<prime[i]<<" "<<prime[j]<<endl;
				if(n == prime[i]+prime[j]){
					ans++;
					//if(i == j){
						//两个素数相等,即n/2为素数
					//	ans+=2; 
					//}
				}		
			}
		}
		cout<<ans<<endl;  //因为n为偶数,当n/2为素数时, 
		
		cin>>n;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值